Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I set up iTunes to download 6 or 7 podcasts in the default location (MyMusic>iTunes>iTunes Media>Podcasts) and put in a share at the Podcasts level and tried it at the podcast name level folder as well.

    The problem is that when any new podcast is added it is not given the same permissions as the folder its in, so even though I can go to the folder and view the contents I cannot play or copy over the podcast until I set the individual permisions for the file to match the folder its in.

    What am I missing to get the file to automatically conform to the permissions of the folder it's placed in?

  2. #2
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Quote Originally Posted by Byron Tarbox View Post
    The problem is that when any new podcast is added it is not given the same permissions as the folder its in, so even though I can go to the folder and view the contents I cannot play or copy over the podcast until I set the individual permisions for the file to match the folder its in.

    What am I missing to get the file to automatically conform to the permissions of the folder it's placed in?
    Hi Byron,

    Right click on the 'Podcasts' folder and select the Security tab. Next highlight your user account in the Group or user names: section. Then click the Advanced button, which will open the Advance Security Settings for Podcasts . Click the Change Permissions... button here. Highlight your User name in the Permission entries: windows and click the Edit button if you need to change the Type to Allow or the Permission to Full Control. If you do not need to edit these, then go to the two check boxes beneath the Add, Edit, and Remove buttons. There should already be a check in the box beside Include inheritable permissions from this object' parent, which is fine if those permissions are the same that you want for Podcasts. Finally, place a check in the box beside Replace all child object permissions with inheritable permissions from this object and click OK

    Alternatively, since your folders within My Music are automatically placed in your Music Library, you could change the permissions in your Music Library for HomeGroup users (which defaults to read only) to Read/Write by right clicking the Music Library folder and selecting Share with Homegroup (Read/Write). Just below that you can select Specific people which takes you to a File Sharing box where you can add users that have profiles on your computer. Be sure your username is listed with the Permission Level as Owner. If you have set Read/Write permissions for Homegroup users, you will see that listed as well. You as Owner should have full permissions in the Music Library. When I copy new songs in my Music Library, I have full permissions to them automatically.

    Hope this helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  3. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks, I think you have pretty much nailed it. I don't know if the Replace all child object tic box is supposed to stay checked or not (it unchecks after apply)? It seems to be working with the podcasts already downloaded but I haven't had a chance to test it with a new one yet so I'll confirm that (or not) in a day or so. And if it doesn't stick for new podcasts....hello XP and simple sharing!!

  4. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well, I think I have it working now, I applied similar security permisions as described in post #2 but I had to go higher in the folder heirarchy to make it work (retain the settings for subsequent downloads). My Music did not seem to work but User account level permissions has so far (1 test).

    At least one thing is for sure, Win 7 is more secure than XP; a 30 second setting in XP has had me scratching for two days in Win 7 just so I can copy podcasts to an MP3 player over a home network from an XP computer.

  5. #5
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Glad you got it working, Byron. Hopefully, your subsequent downloads will inherit the permissions successfully.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •