Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Apr 2001
    Posts
    304
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've developed a signature in Word, with 2 graphics, and saved it as a .htm. I've saved in the Microsoft/Signatures directory, and it has an associated folder of files. My staff have all followed a process to tailor
    it and save it on their computers. Every time one of my staff inserts their signature, they receive the message: "One or more Active X controls could not be displayed because either: 1.) your current security settings prohibit running Active X 2.) you have blocked a publisher of one of the controls." If they OK to that message, the signature will show up in their email, but there is a small little transparent box that appears in the top left hand of the signature, which they need to delete. This is not happening on my machine, which is curious. Any ideas what's going on here? I've tried going into Tools | Options | Security for those machines that are affected. I've changed the Zone to Internet rather than Restricted Sites. I've also tried leaving it Restricted Sites and changing the security level to Medium (the lowest). Help!

    Thanks - Sat

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Satiria View Post
    Every time one of my staff inserts their signature, they receive the message: "One or more Active X controls could not be displayed because either: 1.) your current security settings prohibit running Active X 2.) you have blocked a publisher of one of the controls." If they OK to that message, the signature will show up in their email, but there is a small little transparent box that appears in the top left hand of the signature, which they need to delete. This is not happening on my machine, which is curious.
    Word can be configured to insert specific features associated with company names and addresses: SmartTags. These are the most common cause of ActiveX alerts for HTML authored in Word. Perhaps you have this disabled on your PC, but apparently others do not.

    From the signature folder in Windows Explorer, open the problematic .htm signature file in a text editor like Wordpad and look for those Word-specific features and delete them. If they are not obvious, or deleting them wrecks the design, you can post a "sanitized" version here for review and consultation (in a ZIP or renamed to .txt is best).

    Quote Originally Posted by Satiria View Post
    I've tried going into Tools | Options | Security for those machines that are affected. I've changed the Zone to Internet rather than Restricted Sites. I've also tried leaving it Restricted Sites and changing the security level to Medium (the lowest).
    Don't lower your security! Keeping the default setting alerts you to how others are most likely to experience the message. And of course it protects you from nasties (more critical in Outlook 98-2003 which uses IE under the covers).

  3. #3
    3 Star Lounger
    Join Date
    Apr 2001
    Posts
    304
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks jscher. I was able to remove the Smart Tag info in the signature to stop the Active X message from popping up, so for that problem, your solution was spot on.

    NOW, however, the signature is not holding spacing. I had the font at something very small, like 9 pt., with no added spacing before and after paragraph / hard returns. But for some reason, with the Smart Tags gone, it now want's to put some crazy spacing (almost like a double space) before and after each line in the signature. I'm sure it's something to do with that users' machine, but in the Preview window in the Signatures area it looks FINE. It's only when the signature is actually pulled into a new email that it does the wonky spacing. Do you have any idea what could be causing this?

    Honeslty, I never wanted to use Outlook to create the .htm signature to begin with. I created a graphic and put hyperlinks in the graphic using slices - all in Photoshop - and saved it as an .html file. BUT, since Outlook expects a .htm, it doesn't seem to work right. Some background literature / white pages on Outlook signatures and how they operate, in general, might be helpful if you know where to locate those. OR, if anyone reading this has ever tried to do what I originally wanted to do - use a Photoshop graphic with hyperlinks AS the Outlook signature - PLEASE let me know how to accomplish this.

    Thanks!

    Sat

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Satiria View Post
    I created a graphic and put hyperlinks in the graphic using slices - all in Photoshop - and saved it as an .html file. BUT, since Outlook expects a .htm, it doesn't seem to work right. Some background literature / white pages on Outlook signatures and how they operate, in general, might be helpful if you know where to locate those. OR, if anyone reading this has ever tried to do what I originally wanted to do - use a Photoshop graphic with hyperlinks AS the Outlook signature - PLEASE let me know how to accomplish this.
    The subset of HTML that Word (and Outlook 2007+) understands is a bit more limited than what IE understands and renders. You are further challenged with signatures because you can't effectively use a global style sheet. Still, I don't think it should be very difficult to fine tune the .html (or .htm) to make it work in Outlook. Do you want to post your files for hands-on assistance? If that's not acceptable, try having your users turn off the embedding of SmartTags so they can re-edit your original without introducing ActiveX controls. (Assuming that was the only problem.)

  5. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    Lansing, MI
    Posts
    65
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by Satiria View Post
    the signature is not holding spacing. I had the font at something very small, like 9 pt., with no added spacing before and after paragraph / hard returns. But for some reason, with the Smart Tags gone, it now want's to put some crazy spacing (almost like a double space) before and after each line in the signature
    I believe that if you do not indicate specifically that you do not want additional spacing between the lines, that the default spacing of the signatures takes over, in which case, you get the additional space. Another way to overcome the spacing issue is to use soft returns rather than hard returns where you wish to have the single-spacing (e.g., shift+enter).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •