Results 1 to 2 of 2
  • Thread Tools
  1. New Lounger
    Join Date
    Aug 2010
    Location
    Mercer Island, WA, USA
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have 2 networked computers running Windows 7 64bit. One computer (host) is connected by USB to an HP LaserJet. The Guest account is not enabled on this host computer. All accounts can print. The printer is set up for allowing network printing. A remote computer is networked. Accounts on the remote computer can print to the LaserJet without problems. User passwords are required on both computers and each of the accounts that is able to print from the remote has an account with the same user name/password on the host computer.

    I have been unable to get the Guest account on the remote computer to print to the LaserJet. I've been able to install a printer to the Guest account by logging in as administrator and have printed a test page. Even after the test page is printed the printer doesn't shows up as a device or printer. I've temporarily changed the account type to administrator and tried installing the printer without success.

    I don't want to have the Guest account enabled on the host computer. Is there a way to print from the remote computer Guest account?

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,655
    Thanks
    7
    Thanked 112 Times in 97 Posts
    Hi Robert, and welcome to the Lounge!

    This is probably a permissions issue. After logging in with your administrator account on the Windows 7 machine that has the enabled Guest account, go to Devices and Printers in Control Panel, right click on the network shared default printer and select Printer properties. Next select the Security tab on the Printer Properties page, and you should see Everyone in the list of users. Check the permissions for Everyone. At minimum, Print should be checked in the Allow check box. The print permission granted to Everyone will be sufficient to allow the Guest account to print to the printer.

    If you do not see Everyone listed in the Groups or users names, then click the Add button, and type Everyone in the box labeled Enter the object names to select, and click OK. This returns you to the previous Properties page showing the Group or user names. You should now see Everyone in the Group or user names list. Highlight the Everyone user, and note the permissions that Everyone currently holds, which on my computer is Print under the Allow heading. The Print permission for Everyone should be sufficient to allow Guest to print documents. It does on my home network. If you want to add Guest to the permissions list, just follow the procedure for adding Everyone.

    Log out from your administrator account and log in under the Guest account and you should be able to print. Hope this helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •