I not sure if this has been posted before, so apologies in advance if it has.

I've been using Google Chrome browser for some weeks and I have been really niggled by Chrome refusing to open at the size I want. The bottom always seems to be too far from the Taskbar and the top is a few pixels down the screen.

The solution is to edit the Local State using Notepad. Local State in Windows 7 is found in

Users>UserName>AppData>Local>Google>Chrome>User Data>Local State

Open Local State in Notepad.
Edit the 'Windows_Placement' bottom setting a little at a time until your Chrome windows opens correctly.

FWIW, my monitor runs at 1920 x 1080 and the top is set to 0 and the bottom to 1050.