Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Western NY, USA
    Posts
    157
    Thanks
    0
    Thanked 0 Times in 0 Posts
    How do I change the default macro security level for all users to Medium from high?

    Thanks

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    East Coast, USA
    Posts
    993
    Thanks
    8
    Thanked 43 Times in 43 Posts
    Hello - Try this

    Tools>Security

    Will show the following .....

    [attachment=89662:Excel Options Screen.jpg]

    Then choose Security tab and Macro Security button

    Will show the following .....

    [attachment=89663:Excel Macro Security.jpg]



    Tim
    Attached Images Attached Images

  3. #3
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Western NY, USA
    Posts
    157
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Tim, but that sets the macro security for one user.

    I found it though. I looked in the registry under HKCU to see what changed when I set the macro security, and the applied it to HKLM. It worked. Now whoever logs onto the machine is prompted to run or not run macros.

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Quote Originally Posted by Cecil View Post
    Thanks Tim, but that sets the macro security for one user.

    I found it though. I looked in the registry under HKCU to see what changed when I set the macro security, and the applied it to HKLM. It worked. Now whoever logs onto the machine is prompted to run or not run macros.
    Cecil,

    Ok, give! Which key?
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Western NY, USA
    Posts
    157
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Cecil View Post
    Thanks Tim, but that sets the macro security for one user.

    I found it though. I looked in the registry under HKCU to see what changed when I set the macro security, and the applied it to HKLM. It worked. Now whoever logs onto the machine is prompted to run or not run macros.

    Sorry 'bout that.

    From HKCU to HKLM.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\ Excel\Security]
    "Level"=dword:00000002

  6. #6
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Cecil,

    Thanks for the key.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •