Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Jul 2010
    Location
    Glasgow, United Kingdom, United Kingdom
    Posts
    126
    Thanks
    32
    Thanked 0 Times in 0 Posts
    My laptop HP Pavilion has stopped using my external display.
    In device manager The display adopter has a yellow triangle with a ! Mobile Intel 945GM Express Chipset Family this is duplicated both with a yellow triangle.
    I uninstalled both drivers on rebooting both drivers came back with the same error.
    I went to the Intel site ran their program to find drivers for the chipset found updated drivers and installed them. All to no avail drivers came back with the same error

    M$ tells me "Windows cannot initialize the device driver for this hardware. (Code 37)"

    Help! I need my external display working I tested this with another laptop and the display is fine.
    Jimmy

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,172
    Thanks
    47
    Thanked 981 Times in 911 Posts
    Have you changed the memory config recently? On-board video uses some of the system RAM as video RAM.
    Maybe re-setting the BIOS to the default will fix it?

    cheers, Paul

  3. #3
    2 Star Lounger
    Join Date
    Jul 2010
    Location
    Glasgow, United Kingdom, United Kingdom
    Posts
    126
    Thanks
    32
    Thanked 0 Times in 0 Posts
    No I changed nothing last night it was working this afternoon external display not working

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,172
    Thanks
    47
    Thanked 981 Times in 911 Posts
    Could be a faulty video card. Have you tried the HP diagnostics?

    cheers, Paul

  5. #5
    2 Star Lounger
    Join Date
    Jul 2010
    Location
    Glasgow, United Kingdom, United Kingdom
    Posts
    126
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thank you for your reply.
    The only HP diagnostics I can find is in the BIO set up and is only for HDD

  6. #6
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Jimmy, how did you uninstall the older video drivers?

    Check this MS article for instructions on how to proceed when you receive a Code 37 to see if that helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •