Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Feb 2010
    Location
    Atlanta, GA
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have W7 and MS Office 2003 on my main system. I also have Office 2003 on my laptop running WXP Prof. The Save Settings program apparently contains specific Windows 7 path information. So, when I load the settings into the XP system none of my macros work because they are pointing to a Windows 7 path. Now, I know I can do Customize, right-click each macro button and re-assign the macro manually. Is there anyway to go this in one operation globally?

    Thanks in advance.

    Ed

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Ed,

    Specifically, what macros don't work, Word, Excel, Access, etc, where are they stored, and What paths are giving your problems. The solution may involve the use of Environment variables in your coding. I can be more specific with the answers to the preceding questions.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    Ed,

    As you indicate, the default path for templates is different between Win 7 and Win XP. I don't know the ins and outs of Save Settings, but in general it wouldn't surprise if it doesn't work well going backwards from Win 7 to Win XP.

    Speaking to Word specifically, were your macros previously in your Normal.dot? (that would be the default place where Word would store recorded macros).
    It may be that there's a conflict between where your Word 2003/Win XP application expects Normal.dot to be, versus where the Save Settings programs thinks Normal.dot should be.

    You may be able to fix it by doing the following (which would not involve any coding on your part):

    In Word 2003 on your Win XP computer, launch Word and make sure a document is open.
    Go to Tools > Options > File Locations.
    Click once on the item in the list that says "User templates" and then click on the Modify button.
    This will bring up a Modify Location dialog. Use this to navigate to the following path:
    C:\Documents and Settings\<your user name>\Application Data\Microsoft\Templates
    - and then click on the OK button.

    That should set your User templates location back to the default path. If that still doesn't help, you might want to navigate to that folder using Windows Explorer, and check to see that Normal.dot is indeed in that location.
    I think if you set it this way in Word, it should affect the settings for the other Office apps.

    Worth a try, anyway.

    Gary

    PS: I'll be traveling for the next few days, so there may be a delay in my ability to respond here.

  4. #4
    New Lounger
    Join Date
    Feb 2010
    Location
    Atlanta, GA
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Gary Frieder View Post
    Ed,

    As you indicate, the default path for templates is different between Win 7 and Win XP. I don't know the ins and outs of Save Settings, but in general it wouldn't surprise if it doesn't work well going backwards from Win 7 to Win XP.

    Speaking to Word specifically, were your macros previously in your Normal.dot? (that would be the default place where Word would store recorded macros).
    It may be that there's a conflict between where your Word 2003/Win XP application expects Normal.dot to be, versus where the Save Settings programs thinks Normal.dot should be.

    You may be able to fix it by doing the following (which would not involve any coding on your part):

    In Word 2003 on your Win XP computer, launch Word and make sure a document is open.
    Go to Tools > Options > File Locations.
    Click once on the item in the list that says "User templates" and then click on the Modify button.
    This will bring up a Modify Location dialog. Use this to navigate to the following path:
    C:\Documents and Settings\<your user name>\Application Data\Microsoft\Templates
    - and then click on the OK button.

    That should set your User templates location back to the default path. If that still doesn't help, you might want to navigate to that folder using Windows Explorer, and check to see that Normal.dot is indeed in that location.
    I think if you set it this way in Word, it should affect the settings for the other Office apps.

    Worth a try, anyway.

    Gary

    PS: I'll be traveling for the next few days, so there may be a delay in my ability to respond here.
    Thanks. That worked in Word. Doesn't seem to be working in Excel. But, I admit, I didn't have much time to experiment today.

    I will say, this has always been an issue with MS Office - xfering from one PC to another. It makes me long for the long-ago days of CP/M and DOS and text readable .ini files. At least then one could actually see the settings that were affecting such stuff.

    Thanks for the reply. I'll get back to this tomorrow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •