Results 1 to 13 of 13
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Dallas, Texas, USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I installed Internet Explorer on my Windows XP Professional sp3 computer. I previously was using IE7 without any problems.
    After the installation of IE8 I get the following error when I try to go to any website.

    Internet Explorer has closed this webpage to help protect your computer
    A malfunctioning or malicious add-on has caused Internet Explorer to close this webpage.

    What you can do:
    Go to your home page
    Try to return to google.com
    More Information

    Windows Data Execution Prevention detected an add-on trying to use system memory incorrectly. This can be caused by a malfunction of a malicious add-on.

    Other things you can do:
    Go online to learn about the Data Execution Prevention (DEP) security feature.

    I ran IE8 from the command line using iexplorer.exe -extoff and still got the same error.
    Any help will be greatly appreciated.

    Howard

  2. #2
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Hi Howard, and welcome to the Lounge!

    Have you run any malware scans on your system to see if anything is detected?

    Are you able to get to the Manage Add-ons in IE8. If so, disable all add-ons and restart IE8 to see if you can get to some web sites. If you are able to do so, enable one add-on at a time until IE8 fails again. Then you will know which add-on is causing the problem.

    If you cannot get to the Manage Add-ons, then uninstall IE8 so you revert back to IE7 and confirm that it runs as it should. Then you can download a fresh copy of IE8 for installation.

    I am going to move your thread to the Internet Explorer forum as you may get some more attention there.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Dallas, Texas, USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you for your reply.

    I ran IE8 from the command line using iexplorer.exe -extoff (which means run without addons) and still got the same error.

    Checked for malware and none found.

    Howard

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    If you care to experiment a bit with DEP see XP SP2: How to Turn Off the Data Execution Prevention feature (DEP) | Windows | Tech-Recipes for instructions on disabling DEP for one or more programs. See A detailed description of the Data Execution Prevention (DEP) feature in Windows XP Service Pack 2, Windows XP Tablet PC Edition 2005, and Windows Server 2003 for instructions on how to completely disable DEP.

    Joe
    Joe

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Ashburn, Virginia, USA
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    FWIW:

    I realize that this is NOT a DEP-related answer, but I've recently seen several PCs infected by forcing a Proxy setting in IE.

    In each case, searches for Malware came up empty! Once I removed the bogus proxy settings, IE was able to go to all sites again.

    It might be worth a check: Tools / Internet Options / Connections Tab / Lan Settings Button: You should not (in general) have any checkmarks in the Proxy settings.

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Dallas, Texas, USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks to everyone who responded to my question.

    The solution is as follows:

    Go to Tools->Internet Options->Advanced->Settings->Enable memory protection to help mitigate online attacks, uncheck this option.

    Howard

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Glad you got it resolved. Thanks for posting your solution.

    Joe
    Joe

  8. #8
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Quote Originally Posted by Howard Bock View Post
    Thanks to everyone who responded to my question.

    The solution is as follows:

    Go to Tools->Internet Options->Advanced->Settings->Enable memory protection to help mitigate online attacks, uncheck this option.

    Howard
    This must just be a problem with XP because on my Win 7 systems I have this checked with no issues. Perhaps this is because Win 7 is considered more secure to start???
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  9. #9
    4 Star Lounger
    Join Date
    Dec 2009
    Location
    Paducah, Kentucky
    Posts
    420
    Thanks
    37
    Thanked 67 Times in 64 Posts
    Hi Howard.

    You may have alleviated the symptom of your problem but I'd say you might have something which isn't well behaved.
    I'd still experiment with the Manage Add-ons (as Gerald Shepard suggested above).
    Baring that, I'd run a scan or two for malware.

    I have never seen your problem occur when running IE8 under Windows XP (and I've upgraded IE on lots of PCs).
    Clone or Image often! Backup, backup, backup, backup...
    - - - - -
    Home Built System: Windows 10 Home 64-bit, AMD Athlon II X3 435 CPU, 16GB DDR3 RAM, ASUSTeK M4A89GTD-PRO/USB3 (AM3) motherboard, 512GB SanDisk SSD, 3 TB WD HDD, 1024MB ATI AMD RADEON HD 6450 video, ASUS VE278 (1920x1080) display, ATAPI iHAS224 Optical Drive, integrated Realtek High Definition Audio

  10. #10
    New Lounger
    Join Date
    Dec 2009
    Location
    Dallas, Texas, USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I ran IE8 from the command line using iexplorer.exe -extoff and still got the same error. This ran IE8 without add-ons and I still had the problem.

    I also ran Malwarbytes to check for malware and the PC showed to be clean.

    The following is a reply I got back from Microsoft.

    Analysis:
    ===============
    From the post description, we know that the DEP detect the “malfunction of a malicious add-on”, and because of this error cause the IE8 doesn’t run rightly. So the import factors which cause this issue are DEP and the “malfunction of a malicious add-on”

    Possible solution:
    ================
    Many faults will cause this issue, so let do the following steps to narrow down this issue:
    1) Please do the following steps to reset the IE8:
    For IE8 option, locate to Tools-> Internet Options->Advanced->Reset.
    2) Please do the following steps to disable the Memory protection function:
    For IE8 option, locate to Tools->Internet Options->Advanced->Settings->Enable memory protection to help mitigate online attacks, please uncheck this option

    If the above steps don’t solve this problem, please do the following steps:
    1) Please locate the following location and disable all the add-ons to test:
    For IE8 option, Tools-> Internet Options-> programs-> Manage add-ons-> click right-window feature-> click disable (see the following picture)
    2) Please follow the article to narrow down this issue:
    How to solve Internet Explorer 8 installation problems
    http://support.microsoft.com/kb/949220/en-us


    Since I ran IE8 without add-ons and that did not solve my problem I following their next step which was "For IE8 option, locate to Tools->Internet Options->Advanced->Settings->Enable memory protection to help mitigate online attacks, please uncheck this option" . This did solve my problem although it may be masking another problem.

    I agree with you that something else is causing this problem. It does not appear to be add-ons or malware.

    Do you or anyone else have any other ideas as to how to find the real culprit causing this error.

    Thanks

    Howard

  11. #11
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Howard,

    I assume you ran the correct command iexplore.exe -extoff rather than iexplorer.exe -extoff that you mentioned in posts 3 and 10.

    Do you use a software firewall on your XP machine? If so, disable it to see if that affects IE8 starting. The reason I ask is IE8 has had an issue with Comodo Firewall, where a setting in it prevented IE8 from running correctly. Even if you do not have Comodo, disabling your firewall for a few minutes will not hurt.

    Before you try to run IE8 again, run Task Manager to be sure there are no other instances of IE8 running already. If there are then shut them down. In fact, when you disabled the add-ons, did you check Task Manager to be sure there were no instances of iexplore.exe already running? When IE8 fails, it may still be running under the Processes tab. This could cause a subsequent attempt to run IE8 to fail even if the correct fix is applied.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  12. #12
    New Lounger
    Join Date
    Dec 2009
    Location
    Dallas, Texas, USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The software firewall on my XP machine is turned off.
    There are no other instances of IE8 already running.

    Please let me know if you have any other ideas.

    Thanks,

    Howard

  13. #13
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Howard Bock View Post
    Since I ran IE8 without add-ons and that did not solve my problem I following their next step which was "For IE8 option, locate to Tools->Internet Options->Advanced->Settings->Enable memory protection to help mitigate online attacks, please uncheck this option" . This did solve my problem although it may be masking another problem.
    Perhaps some external malware that detects IE8 starting and modifies it in memory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •