Results 1 to 10 of 10
  1. #1
    New Lounger
    Join Date
    Jan 2001
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Defragmenter Broken

    My Defragmenter seems to be cycling for hours and hours, sometimes in the beginning stage,and sometimes in the defrag portion. It can't seem to get past 0,1,2, or 3% before going back to zero and seldom displays the entire chessboard screen.

  2. #2
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    New Zealand
    Posts
    295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    Steve have you run Scandisk? If not run it first in thorough mode. Also make sure nothing is trying to access the harddisk while these processes are running. Shut down all running programs except explorer and systray then run.

  3. #3
    New Lounger
    Join Date
    Jan 2001
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    Hi Mike,

    The scandisk/thorough also loops. It goes about 25% through and then drops that and goes to allocation segment again.
    Steve

  4. #4
    New Lounger
    Join Date
    Jan 2001
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    Dear Mike,

    NOW you got it. I did as you suggested and deleted everything in the delete box. Except two items.

    In the meantime, I found a uSoft Knowledge base article, # Q238165, Defrag00205, and it told me to delete the applog contents, which I did, and now I can and did run the defragmenter without problem. Thanks

    Steve

  5. #5
    gjgiever
    Guest

    Re: Defragmenter Broken

    As I understand it, every time the program senses that there has been activity, and thus a possible change, it goes back and starts over. Any program running in the background could cause this. When this was happening to me a while back the culprit turned out to be my virus scanner. It was set to scan any disk activity. The two programs were dueling it out. The defragmenter would read a bit then the virus scannerer would jump in to see what the defragmenter had done which would set the defragmenter into "Let's start all over again mode". The easy cure was to turn off the virus scanner when defragmenting.

  6. #6
    New Lounger
    Join Date
    Jan 2001
    Location
    Surprise, Arizona, USA
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    I have a "snoop" program that is running from the network which causes some disk activity every 30 seconds or so. Thus, when this is in operation, using the stock Defrag utility runs similar to your description (although I typically get to 10-12%). I found that I needed to logout for Defrag to run successfully.

    I have found that Executive Software Diskeeper http://www.execsoft.com runs well in a network environment so that may be an alternative.

  7. #7
    New Lounger
    Join Date
    Jan 2001
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    Thanks Gary,
    That may be what was happening, although in the past it has ignored the other conflicting programs. Like Mike suggested, I exited everything, then went to the delete screen and took out all but explorer and systray; that deleted the Virus scan. Before all that, I had deleted the applog file as microsoft had suggested, and it worked!

  8. #8
    New Lounger
    Join Date
    Jan 2001
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    Dear Mr Kinner.
    Thanks for the response.
    See the above thread. Whatever it was we killed it off first and then ran the defragmenter. That did it, and the printer started working to specs again and other things began to happen right away. It is a pleasure to press a button and have something happen immediately, rather than 30 seconds later!
    Steve

  9. #9
    ileacy
    Guest

    Re: Defragmenter Broken

    I ran into a similar problem with my @Home (Rogers).

    They have started port scanning me continuously (approx 500 times every 2 hours). No problem in that they never get through, however Zone Alarm was logging the activity continously to disk.

    Result was that I have to disable Internet access before I
    run any maintenance tasks like Scandisk or Defrag.

  10. #10
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Defragmenter Broken

    I have found that it's best to shut everything off except systray & Explorer whenever you want to do any real housecleaning. That's especially true for:
    scandisk
    defrag
    backups

    A great utility for shutting everything off is EndItAll by Neil Rubenking. You can find it at:

    http://hotfiles.zdnet.com/cgi-bin/texis/sw...cm&fcode=0011NB

    Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •