Results 1 to 3 of 3
  1. #1
    Star Lounger
    Join Date
    Sep 2009
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    I have a two combo boxes on a form. When the user chooses an option on the first combo box, I run some SQL code through the after update event to fill in options on the 2nd combo box. This works fine and the user is able to choose the option they wish on the 2nd combo box. If I navigate to a new record and back to the original record, both combo boxes have values in them showing what the user chose.

    If I close the form however and then reopen, the value on the 2nd combo box comes up blank, even though there is a value in the underlying field on the table.

    Does anyone know why this is happening?

    Cheers,
    Jason

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts
    The code you have in the After Update event for the first combo box needs to be repeated in the On Current event for the form. Without that the second combo does not have the correct options available when looking at existing data.
    Regards
    John



  3. #3
    Star Lounger
    Join Date
    Sep 2009
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thankyou so much John, that works perfectly. Much appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •