Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Brookline, Massachusetts, USA
    Posts
    606
    Thanks
    17
    Thanked 0 Times in 0 Posts
    Today, suddenly, when I click a link in an email, IE launches, not Firefox. IE comes up with my home page, not the page in the link. Tried another link, same result. Checked the settings. Firefox says it's the default browser. IE says it is not the default browser. Recent changes: Last night I installed Adobe Reader and Flash updates and all the Sept Vista patches. Did not install Oct patches on advice from Woody (Defcon 2). Is this malware? My Norton Internet Security is up to date. I can launch Firefox separately.
    HH

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Have you tried the double switch -- make IE your default browser, then make Fx your default again? Sometime that will refresh the settings and resolve an otherwise inexplicable issue.

  3. #3
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Brookline, Massachusetts, USA
    Posts
    606
    Thanks
    17
    Thanked 0 Times in 0 Posts
    Good idea. Will try it soon. But, what cause IE to launch only my home page, regardless of the link? If I paste the link into Firefox, it works fine. Ditto if pasted into new tab in IE.
    HH

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Howard Hillman View Post
    But, what cause IE to launch only my home page, regardless of the link?
    The registry stores "open" actions for HTTP and HTTPS links, each of which should end with a parameter to pass the URL. Maybe that parameter placeholder is missing or corrupted? The old way to easily access that information was Windows Explorer's Tools > Folder Options > File Types tab. But if I recall correctly, that UI is hidden in Vista.

  5. #5
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Brookline, Massachusetts, USA
    Posts
    606
    Thanks
    17
    Thanked 0 Times in 0 Posts
    Problem solved. A reboot was all that was required. Thanks for your suggestions.
    HH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •