Results 1 to 5 of 5
  1. #1
    Silver Lounger
    Join Date
    Dec 2000
    Location
    Northampton, Northamptonshire, England
    Posts
    1,951
    Thanks
    2
    Thanked 1 Time in 1 Post
    I have attached some macro's to shapes in a worksheet, they just select other worksheets, and don't want them to print is this possible?, if so I would appreciate a litte help.

    Thanks in advance

    Regards

    Braddy
    If you are a fool at forty, you will always be a fool

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Braddy,

    1. Right-Click on the shape.
    2. Select Format Autoshape...
    3. Click on the Properties tab.
    4.Then uncheck the Print object box.
    5. Click OK.

    You should be good to go.

    If you want to do multiple shapes in one shot hold down the SHIFT key while Left-clicking them then Right-Click on any one of the borders. and continue as above with step 2 above.
    Attached Images Attached Images
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    Silver Lounger
    Join Date
    Dec 2000
    Location
    Northampton, Northamptonshire, England
    Posts
    1,951
    Thanks
    2
    Thanked 1 Time in 1 Post
    Hi

    Thanks for the reply, unfortunately I don't get what you get with this action. see jpg

    I am using Excel 2007

    Regards

    Braddy
    Attached Images Attached Images
    If you are a fool at forty, you will always be a fool

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Braddy,

    Sorry, I was using 2003. I fired up my laptop that has 2007 and we've been upgraded.

    1. Right-Click on the shape.
    2. Select Size and Properties...
    3. Select the Properties tab.
    4. Uncheck the Print Object checkbox.
    5. Click Close.

    BTW: It's always a good idea to include your version information in your post.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    Silver Lounger
    Join Date
    Dec 2000
    Location
    Northampton, Northamptonshire, England
    Posts
    1,951
    Thanks
    2
    Thanked 1 Time in 1 Post
    Hi

    My apologies your quite right I have been around here long enough to know I should have stated my version.

    Everything is fine now thanks again

    Braddy
    If you are a fool at forty, you will always be a fool

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •