Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    I've created a footer on pages 2-end of the document that has 3 textboxes with text. There's room to the right of the right-hand textbox for a page number. I know this becuase I modeled the footer on that of another report. When I use Insert>Page Number>Bottom of Page>Plain Number 1(or any type, but Plain Number 1 is preferred), my footer text boxes dissapear. Obviously, I want to avoid this. I notice in another of our reports that the right-hand text in the footer isn't in a text box, so perhaps the problem is that I have placed this right-hand text in a text box? That doesn't explain though why the page number removes all three of the text boxes (the report I am modelling this on does have two text boxes). Any suggestions? Thanks.

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Use Insert>Page Number>Current Position>Plain Number 1 instead. Or after selecting "Insert>Page Number>Bottom of Page>Plain Number 1", right click and choose "Insert at current document position".

    Pam
    Pam Caswell

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    Just expanding on Pam's solution a bit: the problem wasn't being caused by your having textboxes in the footer already, the problem is caused by Word 2007's behavior where inserting any of the page number Quick Parts replaces whatever content was already in the header or footer.

    Using 'Current Position' rather than 'Bottom of Page' causes the page number Quick Part to be inserted in the footer, rather than replacing what's in the footer.

    Gary

  4. #4
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hmm, tried "current position" and the page number appeared but removed the two text boxes to the left of it that were on the same horizontal level. The text box that was below it remained, however. So, still removing text boxes. Also, I didn't see any "Insert at current document position" after right-clicking on the spot in the header after following the "Insert>Page Number>Bottom of Page>Plain Number 1" steps.

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Considering that long menu path, might it be easier to type (don't type the spaces):

    Ctrl+F9 p a g e F9

    Just a thought...

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    For what it's worth, I can't reproduce the problem of textboxes to the left being removed, when the page number is inserted to current position. Maybe I'm setting up my test differently from how your document is laid out.

    But if the textboxes are causing a problem, why not avoid using them? Could you optionally lay out your required footer content, using a table (with no visible borders, just using the table as a layout structure)? You could then insert the page number in one of the table cells.

    Gary

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •