Results 1 to 2 of 2
  1. #1
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Hi All,

    I've decided to start learning PowerShell and although I've ordered a couple of books I don't have them yet. I've been working with the "Windows PowerShell Primer" {downloaded from MS}. My problem is that every time I try to execute the command: get-WmiObject -Class Win32_BIOS -ComputerName [computername] I get a RPC error {see graphic}. I've done some research on the net and I've tried turning on services and configuring the firewall with NetSh advfirewall set currentprofile settings remotemanagement enable on both my Desktop & Laptop {both 64Bit Win 7}.

    Additional Info: There are 4 PCs on the network (2) Win-7 64 Bit, (1) Win-7 32 Bit, (1) WinXP Pro XP-3.
    I am NOT using Homegroups. See graphic 2 for relevant services settings.

    Any Ideas?
    Attached Images Attached Images
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    From what I can find this error is often a firewall problem.

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •