Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Austin, TX , USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My computer has been running slow lately and Process Explorer reports that it is MsMpEng.exe using up to 80% of my CPU. MsMpEng.exe is the "AntiMalware Service Executable" component of Microsoft Essentials. A Google search indicates that this has been a problem with MSE for a long time.

    I am ready to jettison MSE. Does anybody have any ideas of what to do about this?

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    What operating system?

    Do you have the latest MSE installed?

    Is it running a scheduled scan?

    Joe
    Joe

  3. #3
    New Lounger
    Join Date
    Jan 2011
    Location
    Reno, NV
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    On Windows Secrets recommendation I installed MSE on my 2 desktops and my laptop. One desktop and the laptop run normally, but I finally had to take MSE on my other desktop and go to AVG. With MSE installed, I first noticed that my desktop icons took almost 10 minutes to come up and during that time, I was unable to start e-mail, Internet, or any other program. In Task Manager I found that MsMpEng.exe was utilizing 99% on my CPU time. It would keep fluctuating between about 45% to 99% CPU time with 99% most of the time. The icons on my desktop would begin loading at about one ever 30 seconds. When I ended the process, MSE would stop running so I r ealized MsMpEng.exe was tied to MSE. When I uninstalled MSE, MsMpEng.exe was gone and my desktop icons loaded immediately and I was able to open any program right away. Googling MsMpEng I found this process has been causing the same problem with other users for years. I didn't know MSE had been around that long, but there were posts going back years. I tried several suggested remedies, but MsMpEng remained a CPU hog.

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Austin, TX , USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    MSE 2.0 seems to be better behaved. I have set the max CPU usage to 20% and am happy with it so far.

  5. #5
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    6,121
    Thanks
    160
    Thanked 609 Times in 557 Posts
    An upgrade to MSE version 2.0 will alow for CPU usage modification for those experiencing difficulties or have weaker system specs.
    Sometime a reinstall of the same version app will correct this too.
    DRIVE IMAGING
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Build your own system; get everything you want and nothing you don't.
    Latest Build:
    ASUS X99 Deluxe, Core i7-5960X, Corsair Hydro H100i, Plextor M6e 256GB M.2 SSD, Corsair DOMINATOR Platinum 32GB DDR4@2666, W8.1 64 bit,
    EVGA GTX980, Seasonic PLATINUM-1000W PSU, MountainMods U2-UFO Case, and 7 other internal drives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •