Results 1 to 13 of 13
  1. #1
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    London
    Posts
    703
    Thanks
    256
    Thanked 4 Times in 4 Posts
    I subscribe to a certain financial website and visit it almost every day. Apart from the audio commentary on world markets and the c17000 charts, they have extensive textual content on investing matters, which I rarely have time to read.

    Two weeks ago last Friday there was something I wished to read and the link would not work. Trying every link that day I found some opened and most didn’t. The next week I tried every link each day, with the same result. So on the second Friday I sent an email asking them to check their links, as I did not think it could be my PC in view of the variable results. I detailed the result of each individual link the previous day. The reply stated that they had found no problems with the links and had not received any other complaints, so felt the problem must be at my end.

    Further investigations revealed that:
    1. It’s is only PDF reports which will not open, neither with Foxit or Nitro readers,
    2. there is no problem if using IE, and
    3. they open using Firefox on my wife’s PC

    So the problem is FF on my XP machine. I have disabled the BetterPrivacy and Close n forget add-ons in case they were the cause, without success.

    Today I discovered that if I save the link to the desktop it will open from there, which is easier than changing browser or PC. However, in the meantime another issue has arisen.

    FF will not accept downloads - the screen shows the file downloading, then says ‘Done’ but is otherwise blank, and it can not be found anywhere. So I have to switch to IE to download, which involves making it the default browser.

    I feel that these issues are probably related, due to the proximity in time between the two, and they both involve downloads, but the absence of any similarity between the settings in FF and IE does not help find the solution.

    Any suggestions on how to proceed would be much appreciated.

    George

  2. #2
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi George, Try these settings.

    [attachment=90634:1.JPG]

    [attachment=90635:2.JPG]
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by George Lee View Post
    Today I discovered that if I save the link to the desktop it will open from there, which is easier than changing browser or PC. However, in the meantime another issue has arisen.

    FF will not accept downloads - the screen shows the file downloading, then says ‘Done’ but is otherwise blank, and it can not be found anywhere. So I have to switch to IE to download, which involves making it the default browser.

    I feel that these issues are probably related, due to the proximity in time between the two, and they both involve downloads, but the absence of any similarity between the settings in FF and IE does not help find the solution.
    Regarding downloads in general, if you open the Downloads list (Ctrl+J) do you have a lot of history? You may want to clear the list.

    Do you get the Open/Save dialog and then nothing happens after that? Or do you never get that dialog?

    Regarding PDFs, check Tools > Options > Applications. On my system, PDFs are called Adobe documents, but this may be different on your system. See whether changing the download action helps with those.

  4. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    East Coast, USA
    Posts
    993
    Thanks
    8
    Thanked 43 Times in 43 Posts
    Hi George - What version of FF is used? The recent update of FF to 3.6.12 has been causing problems for some users.
    The update is within your referenced time frame.

  5. #5
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,792
    Thanks
    117
    Thanked 798 Times in 719 Posts
    After the download says "Done", go to Tools>Downloads and you should see your download at the top of the list. Double click to open the file or right click on it for other options including open containing folder if you want to see where it is stored.

    Jerry

  6. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    London
    Posts
    703
    Thanks
    256
    Thanked 4 Times in 4 Posts
    Thank you gentlemen.

    Roderunner -settings now as per your screenshot, except for the homepage. Should I change that also?


    jscher2000
    - control+j produces a screen with 'Downloads' at the top, 'Clear List' greyed out at thew bottom and the remainder blank.

    Open/Save appears when downloading updates, followed by 'done' with a blank screen. In the case of PDF files it goes to the blank screen almost instantaneously.

    Tools > Options > Applications contains nothing that refers to PDF files.

    Tim - yes it's version 3.6.12. I think you have found the cause. Looks like I'll have to wait for the next update. The same version is not causing a problem with Vista, but you said it only effects some users.

    Jerry - your suggestion leads to the same blank screen mentioned above in response to jscher2000.

    I thank you all for your responses, but it seems probable the problem is caused by the current version of Firefox, as mentioned by Tim.

    George

  7. #7
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Quote Originally Posted by George Lee View Post
    Roderunner -settings now as per your screenshot, except for the homepage. Should I change that also?
    George
    It's your choice, I use it because I use Gmail (when set correctly it's the best). I also do this:-

    [attachment=90650:w.JPG]
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by George Lee View Post
    control+j produces a screen with 'Downloads' at the top, 'Clear List' greyed out at thew bottom and the remainder blank.
    Okay, so too much accumulated history definitely is not the problem.

    Quote Originally Posted by George Lee View Post
    Open/Save appears when downloading updates, followed by 'done' with a blank screen. In the case of PDF files it goes to the blank screen almost instantaneously.

    Tools > Options > Applications contains nothing that refers to PDF files.
    I'm not sure what you mean by "downloading updates." If you click a link to a binary file (e.g., an email attachment or a file attached to a post in the forum), you should get an Open/Save dialog that doesn't change the underlying web page. If you get a blank screen for a PDF link, it implies that the browser is configured to open PDFs in a tab rather than launching them in an external program, such as the Foxit or Nitro reader application. Check the options within those programs to see whether you can switch that. For example, in Adobe Reader, you would use Edit > Preferences > Internet, and uncheck the box for "Display PDF in browser." Does something like that exist in your readers?

  9. #9
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    East Coast, USA
    Posts
    993
    Thanks
    8
    Thanked 43 Times in 43 Posts
    Hi George - You can check the dates of your FF update to 3.6.12 and see how close it is to when the FF problems started......


    [attachment=90651:Firefox Foxit PDF issues.jpg]


    This link may add some info for Foxit issues .....
    Problem opening pdf files from firefox with firefox reader


    ,,
    Attached Images Attached Images

  10. #10
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    London
    Posts
    703
    Thanks
    256
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by Tim Sullivan View Post
    This link may add some info for Foxit issues .....
    Problem opening pdf files from firefox with firefox reader

    ,,
    Hi Tim,

    That’s it!

    The very first item reads ‘Run Foxit Reader, go to Tools/ Preferences/ internet/ check “display PDF in browser”

    It must have become unchecked somehow, because after ticking the box PDFs open immediately in Foxit, though Nitro takes longer.

    I had already discovered a workaround – right clicking the link and selecting ‘open target link in IE’ worked well, and was much quicker than opening IE, making it the default browser, then going back to the link.

    Tim, I am very grateful for your help in bringing this to a successful conclusion.

    George

  11. #11
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    East Coast, USA
    Posts
    993
    Thanks
    8
    Thanked 43 Times in 43 Posts
    George - Thanks for your kind comments. It is always a pleasure to work on your projects.

    Tim

  12. #12
    Lounger
    Join Date
    Apr 2002
    Location
    Polk City, Florida, USA
    Posts
    31
    Thanks
    3
    Thanked 4 Times in 2 Posts
    Every once in a while I come across a PDF than hangs late in the "open" process. I have always been able to download it successfully using "save link as". A possibly related issue: lately (since 3.6.12, maybe?) embedded YouTube links throw an error message, but I can always click on the "Open in YouTube" link and see the video.

  13. #13
    Lounge VIP bobprimak's Avatar
    Join Date
    Feb 2009
    Location
    Hinsdale, IL, USA
    Posts
    2,482
    Thanks
    176
    Thanked 152 Times in 129 Posts
    Quote Originally Posted by George Lee View Post
    Hi Tim,

    That's it!

    The very first item reads 'Run Foxit Reader, go to Tools/ Preferences/ internet/ check "display PDF in browser"

    It must have become unchecked somehow, because after ticking the box PDFs open immediately in Foxit, though Nitro takes longer.

    I had already discovered a workaround – right clicking the link and selecting 'open target link in IE' worked well, and was much quicker than opening IE, making it the default browser, then going back to the link.

    Tim, I am very grateful for your help in bringing this to a successful conclusion.

    George
    Both Foxit Reader and Firefox had upgrades at nearly the same time. This may be when and how the checkbox got unchecked. When upgrading either or both of these programs, they tend to revert to the default settings. This happens to me on my WinBook laptop all the time, and it is annoying.
    -- Bob Primak --

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •