Results 1 to 12 of 12
  1. #1
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Having searched the lounge for a similar problem, I found it, with an advise from jscher2000 on how to fix the problem.

    The thread goes here: Link to old thread from 2009-03-05

    Unfortunately, this fix doesn't work for me, which makes me think that there may be a different issue with my file.

    When trying to open a document, a pling and a friendly pop-up box informs me that "The file Xxx 05.docx cannot open, as there are problems with the contents". The 'Details' field says "Unspecified error"; [Address: Part:] /word/header1.xml, Line; 2, Column: 3380
    (the words in the square brackets may not be correct, as I am trying to translate it from my Danish version of Word).

    I tried to follow jscher2000's advise, but the effort ended with the same error message.

    The problem has occured on three different files in the same folder. Same error message on all three files.
    My first reaction was to delete the bad files and recreate them from scratch, which made me 8 hours older, and to no avail. Same error message came up when I tried to re-open the new files.
    I keep 12 files in the folder, all created from the same home-made template, which contains 20 different styles. Strangely, the problem seems to only affect those 3 files.

    I wonder if anyone has experienced a similar problem in the last year and a half since jscher2000's reply? And maybe found a new solution?

    App: Word 2007
    OS: XpPro

    Thanks in advance.


    /Hougs

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    I'm guessing from the reference to /word/header1.xml that there is a problem in the header. Can you think of anything unusual in the document header that might be causing a problem?

  3. #3
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi there

    There is nothing unusual or any extraordinary things in the headers and footers. Actually, when I made the docs I 'recycled' one of the good documents, removed the contents of that and added the new contents to two cells in the header.

    The header consists of a table, 4 columns and 2 rows. Different first page header. Some of the contents are bookmarked, so it can be re-used in the headers on the next pages. The header on the next pages consists of a table with 4 columns in 1 row. No section marks or other fancy stuff in there, only cross references to the bookmarks in the header on page 1.

    Track Changes and Comments are active (although I haven't figured out why a comment cannot be inserted in a header - but that is another issue).

    I tried to open the affected docs in LibreOffice. One doc could pass, but it looked nothing like what I put in it. Notepad++ can open the docs, but it is all gibberish.


    Thank you jscher2000 for your quick reply and interest in helping out. Really appreciated.


    /Hougs

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Can you post one of the problem documents? If the contents are too proprietary or confidential, send me a Private Message on the board to arrange an email review.

  5. #5
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I would like to send you a pm with one of the bad files.
    However, I cannot find "Send a message" button below your profile picture.
    Tried the help function, but it wasn't really helpful.


    /Hougs

  6. #6
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Morden, Surrey, United Kingdom
    Posts
    1,838
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hi Hougs

    If you click on JScher2000's name against any of his posts, it will take you to his profile. The 'send a message' link is below the picture there.
    Beryl M


  7. #7
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Beryl

    Thanks for the reply. However, I see no "Send a message" button under jscher2000's profile picture.

    The buttons I see are:
    - Add me as a friend
    - Find threads started by this member
    - Find poste by this member
    - Display name history


    /Hougs

  8. #8
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Morden, Surrey, United Kingdom
    Posts
    1,838
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hi Hougs

    On your own profile, go to Settings, UNcheck 'disable private messages' and Save. The link will then reappear on people's profiles.
    Beryl M


  9. #9
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Beryl

    That did the job! The button is there.


    Wishing you a good weekend.


    /Hougs

  10. #10
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Morden, Surrey, United Kingdom
    Posts
    1,838
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Beryl M


  11. #11
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by hougs View Post
    When trying to open a document, a pling and a friendly pop-up box informs me that "The file Xxx 05.docx cannot open, as there are problems with the contents". The 'Details' field says "Unspecified error"; [Address: Part:] /word/header1.xml, Line; 2, Column: 3380
    (the words in the square brackets may not be correct, as I am trying to translate it from my Danish version of Word).
    Summary of file repair:

    1. Unzip the DOCX file
    2. Open \word\header1.xml in a text editor (I used PSPad) and scroll to column 3380 (indicated by the horizontal red bar):

      <w:r w:rsidDel="00B017BE"><w:rPr><w:rStyle w:val="Kommentarhenvisning"/></w:rPr><w:commentReference w:id="77"/>|</w:r>

      Also open the file in IE and use Find to locate that same area (to get a hierarchical view so it was easier to understand the context)

      Hmmm... should there be a comment in a header??
    3. Delete <w:commentReference w:id="77"/> and save the file
    4. Zip all the files and folders into a new DOCX
    5. Open in Word to test.

  12. #12
    New Lounger
    Join Date
    Sep 2002
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Although I have sent a thank you by private mail to jscher2000, I will not miss this opportunity to say thanks to you here in the lounge.



    You did a marvellous job, which made it possible for me to keep a deadline - and have a lazy Saturday.


    /Hougs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •