Results 1 to 13 of 13
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have an Excel spreadsheet that contains eight dynamic charts that refer to named ranges and forumlas to update the chart views. Using slider bars at the top of the page to Scroll and Zoom, the user can dynamically update the charts to view the tables of data. This works great. My problem is I have two users of the charts, that worked for them at one point, quit working and are frozen on a date and zoom factor. Clicking the slider bars does not update the charts.

    These two users are half way around the world and I can't readily look at their setup, but we have gone through all settings on their machines, and can't find anything different from mine. When they send me their copies of the report, the charts work perfectly on my machine. The only setting that I can change to create the problem on my machine is "Automatic Calculation" set to manual. On the two users machine this is set to automatic, which is where it should be. The sliders are working since they can see the numbers change in the cells that they are linked to, when they click on the controls.

    I've attached the report for your inspection.

    Does anyone have any idea why this quit working on their machines and what I can do to restore the capability?
    Attached Files Attached Files

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Scott,

    What version of Excel are your users using and have the upgraded recently? If they recently upgraded to 2007 or 2010 there are new security settings which may be killing your macros. They should look at the Trust Center settings under Trusted Locations and add the directory the files reside in to the list.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Scott Baker View Post
    The only setting that I can change to create the problem on my machine is "Automatic Calculation" set to manual. On the two users machine this is set to automatic, which is where it should be.
    One can easily obtain a false indication of the 'Calculation' setting. Ensure the file of interest is open and active at the time the Tools > Options pulldown is actioned.
    Regards
    Don

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by RetiredGeek View Post
    Scott,

    What version of Excel are your users using and have the upgraded recently? If they recently upgraded to 2007 or 2010 there are new security settings which may be killing your macros. They should look at the Trust Center settings under Trusted Locations and add the directory the files reside in to the list.
    Everyone is running 2007 and have had it for awhile. We've compared all the settings in Excel over the phone. As I said, it used to work, in 2007, then stopped. Really weird.

    Scott

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Don Wells View Post
    One can easily obtain a false indication of the 'Calculation' setting. Ensure the file of interest is open and active at the time the Tools > Options pulldown is actioned.
    I've had them press the recalc button on the Formulas ribbon, while on the sheet with the charts, still no change. I'm at a loss.

  6. #6
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    I understand that all users are running 2007 yet the file which you posted is in 2003 compatible format (.xls). Can you confirm the extension currently attached to the files on your problem machines?
    Regards
    Don

  7. #7
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Scott Baker View Post
    I've had them press the recalc button on the Formulas ribbon, while on the sheet with the charts, still no change. I'm at a loss.
    Instead of pressing the recalc button on the Formulas ribbon, try pressing "CTRL+ALT+SHIFT+F9". Just a shot in the dark; this should rebuild the workbook calculation tree and do a forced recalculation.
    Regards
    Don

  8. #8
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hi Scott

    In the attached file I have added a hidden sheet (Names), which links to each of the named variables, This should force a complete recalculation.

    Perhaps after saving it as an Excel 2007 file you could pass it to your problem users to determine if it solves the problem.

    In the final analysis I suggest that the hidden sheet be made 'very hidden'. If you should require assistance in doing this, feel free to post back and I will send detailed instructions.

    H.T.H.
    Attached Files Attached Files
    Regards
    Don

  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Don Wells View Post
    Hi Scott

    In the attached file I have added a hidden sheet (Names), which links to each of the named variables, This should force a complete recalculation.

    Perhaps after saving it as an Excel 2007 file you could pass it to your problem users to determine if it solves the problem.

    In the final analysis I suggest that the hidden sheet be made 'very hidden'. If you should require assistance in doing this, feel free to post back and I will send detailed instructions.

    H.T.H.
    Don,
    Thanks for the new sheet, I'll send it to the users on Monday when I get back to my office. To answer your earlier question, I saved the file as an .xls, before posting it here, it was originally a .xlsm file, since it used to have other sheets that had macros associated with them, which weren't pertinent to this problem, so I removed them before posting. The macros work and the other sheets are fine, it's just these charts that quit working. I know how to make a sheet "very hidden", thanks for the help.

    Scott

  10. #10
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Scott

    Please be certain to advise me of the results.

    Thanks
    Don
    Regards
    Don

  11. #11
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hi Scott

    I have attached a macro to the sliders which will update the charts --I believe independent of any settings other than macro security.

    Please let me know how it works out.

    File upgraded with this edit to protect against scrolling past the end of the data set.
    Attached Files Attached Files
    Regards
    Don

  12. #12
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Don Wells View Post
    Scott

    Please be certain to advise me of the results.

    Thanks
    Don
    Don,
    I sent the first spreadsheet you had created, that had the hidden sheet, to the user last night. He reported back this morning that the charts still didn't update. So I sent him the second one, with the macro, this morning. I should have an answer back by 4:00 PM PST. I'll post back as soon as I hear.

    Scott

  13. #13
    New Lounger
    Join Date
    Dec 2009
    Location
    San Diego
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This problem was corrected by the users installing the SP2 update to office. Thanks for all the input.

    Scott

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •