Results 1 to 8 of 8
  1. #1
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    431
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Our accounting program's sends reports as a .RTF file attachment which Outlook blocks. Making registry changes hasn't made any difference. I was hoping to find a way to correct this now that I have everyone moved to a new mail server but haven't found it yet. Isn't there something I can do on our Exchange 2010 to lift the ban on .RTF file attachments?
    Daisy

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,579
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    By default .RTF files are NOT blocked by Outlook 2010. See Attachment file types restricted by Outlook 2010 for the default list of blocked types and Plan attachment settings in Outlook 2010 for information on managing the blocked types. Also, see Attachment file types blocked by Outlook - Outlook - Microsoft Office.

    For Exchange 2010 see Understanding Attachment Filtering and Configure Attachment Filtering.

    Joe
    Joe

  3. #3
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    431
    Thanks
    0
    Thanked 3 Times in 3 Posts
    I know they're not on the list but they are being blocked just the same. "Outlook blocked access to the following potentially unsafe attachments: omega.rtf."

    What happens is the accounting program has an option to print to email and when you select that it opens a new blank email with the attachment omega.rtf only the attachment is blocked. I notice that there's something called "ommapi" in the taskbar when this happens. It won't let me access to view what it is. It goes away when the email is closed.

    I've tried the registry tweaks found all over the Internet but they didn't work. I tried group policy to permit RTF files and it didn't make any difference either.

    I'll go back to the accounting vendor and complaint some more to them. It makes no sense really. The files really are RTF docs.
    Daisy

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,579
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Did you check the Exchange articles and settings?

    Perhaps there is a policy being pushed that overrides your registry changes.

    Joe
    Joe

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Lafayette, Colorado, USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Have you tried creating a simple RTF file using Wordpad and attaching that to an email to see if that is blocked? If so, then the accounting software is doing something funny in trying to send to email. If you can't attach that basic of an RTF doc, then Outlook is probably the program blocking it and not necessarily Exchange.

  6. #6
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    431
    Thanks
    0
    Thanked 3 Times in 3 Posts
    I apologize for not responding to this sooner. I went on a long holiday in mid-December to care for a sick relative and promptly forgot after my return. The problem is now solved. This is what I learned and how I solved it.

    Turned out the problem wasn't just with the one person in accounting. I could replicate it on other computers, in ways not associated with the accounting program. For most tests, I used my personal Gmail account to send a small RTF file to my office email address. We were also unable to attach RTF files to emails created in office with Outlook 2003 or 2007.

    We use Exchange 2010 setup with simple Hub Transport role which means the links above weren't help as they related to the Edge Transport role and it's Attachment Filter abilities.

    We use Script Logic Desktop Authority for managing computers via login scripting. I tried pushing various combinations of group policies including Microsoft Office Outlook 2007\Security\Security Form Settings\Attachment Security to either limit or disable Level 1 and Level 2. This made no difference.

    I also installed the Group Policy Management console on a domain server so I could find and examine all policies in play. None of them related to Office or Outlook. We've always managed those with the login script software but I had to look there to rule it out, of course.

    I eventually found a registry value that was blocking the RTF files and used the login scripting to delete it. It was Level1Add located at HKCU\Software\Policies\Microsoft\Office\12.0\Outlo ok\Security\ Deleting that value solved it. No idea how the heck that setting made it into the registries. I didn't know about the Level 1 or Level 2 security options until looking for the solution.

    My luck, the accounting software upgrade scheduled to occur in five weeks will probably eliminate RTF files all together, but there had to be a solution because this didn't just effect that small department. Thank you for your patience and advice. It was very much appreciated.
    Daisy

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,579
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    FWIW, if you have a simple Exchange server setup (i.e. one server, no edge server) most of the information about edge servers applies to your server since it really has edge server responsibilities too. The problem is figuring out which of the "most" is which.

    BTW, glad you solved it. Outlook & Exchange can be most challenging.

    Joe

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by ailios View Post
    I eventually found a registry value that was blocking the RTF files and used the login scripting to delete it. It was Level1Add located at HKCU\Software\Policies\Microsoft\Office\12.0\Outlo ok\Security\ Deleting that value solved it. No idea how the heck that setting made it into the registries. I didn't know about the Level 1 or Level 2 security options until looking for the solution.
    I'll take a wild guess that there was a major security issue with RTFs at some point, so someone applied a FixIt to those users and then forgot to remove it once the vulnerability was patched.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •