I have just downloaded and installed Firefox version 3.6.13. When starting the new version, it wants me to "upgrade to the latest and safest", which happens to be 3.6.12.
What's up?
Adam