Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2010
    Location
    The Netherlands
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all,

    I'm a bit lost with this and hoping someone can help.

    I have a Sitecom 300n XR USB wireless adapter. When I first plugged it in, it installed without a problem and was showing a max speed of 150mbps. It worked fine like this on any of the 4 machines I have at home. A few days ago I noticed that the connection was slower than normal, I checked the speed and it is now showing 65mbps. (nic card - status)

    I plugged it into my laptop and other machines and it is showing the same slower speed on all of them?

    The machine I use it most on is running Win XP Home, SP3 - All available updates installed. I have a 120 meg download broadband cable connection and a Linksys WRT160N broadband router. Security is WPA2-PSK and I get approx 90 - 95% strength indication shown.

    I do realize that I can't get the full speed that my connection allows as the router is limited to 100 mbps.

    I just can't understand why the adapter changed from 150 to 65 without any changes to any settings. The fact that it is self installing means that I have no idea how to upgrade or check the driver?

    Apologies if I have given too much system info etc, just wanted to ensure that anyone that may be able to help would have as much detail as possible.

    Thanks,

    Hugh.

  2. #2
    5 Star Lounger chowur's Avatar
    Join Date
    Mar 2010
    Location
    Indiana
    Posts
    804
    Thanks
    0
    Thanked 54 Times in 51 Posts
    There's no date on the update driver for your device on the web site.Never the less their is an update;Sitecom I understand it's a plug-n-play situation products such as your's as well as many others update drivers often.
    Problems cannot be solved by the same level of thinking that created them. -Albert Einsten

  3. #3
    New Lounger
    Join Date
    Dec 2010
    Location
    The Netherlands
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks...I tried updating the driver from device manager but? Just makes no sense to have a max speed of 65mbps on this device.

    Hugh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •