Results 1 to 10 of 10
  1. #1
    Lounger
    Join Date
    Mar 2007
    Location
    Houston, Texas, USA
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Shown below is the is the exact problem a user here is having. The only response I've seen is that it is a known bug and Microsoft is aware of it. But, that was some time ago, so I'm curious if any of you know if anything has changed. Or do you know of any way to prevent this behavior.

    Thanks.


    Word 2003 "corrects" spelling when I insert an optional hyphen
    --------------------------------------------------------------------------------
    When I manually insert an optional hyphen (Ctrl+-) in certain words, Word
    will automatically "correct" the word, so it makes the first part correct but
    the whole word wrong! For instance, if I insert this optional hyphen:
    documen-tation, Word will insert another "t" before the hyphen so it changes
    to document-tation. How do I keep this from happening?

  2. #2
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Hi ATPWordPro,

    When I tested this in Word 2003, AutoCorrect didn't barge in and try to fix "documen," but it did when I tested in Word 2007. There is a setting in AutoCorrect that should fix this.

    This is true in both 2003 and 2007: Open AutoCorrect -- make sure you're on the main tab. Uncheck the box at the very bottom: "Automatically use suggestions from the spelling checker" This doesn't interfere with the spell-checker (the wavy red line still appears), nor with the list of words that AutoCorrect uses for "Replace text as you type." But it won't automatically correct misspelled words that are not in the AutoCorrect "Replace text as you type" list.

    I found this feature switched ON by default in 2007, and OFF in 2003 (or perhaps I switched it off in antiquity). I've never experienced any fall-out from it, but your mileage may vary. If you rely on Word fixing your spelling as you type, you probably won't want to turn it off.

    Anyway, you might try this and see if there are any unintended consequences.

    Best, Kim

    (Edited for clarity... oops)
    Attached Images Attached Images

  3. #3
    3 Star Lounger
    Join Date
    Sep 2001
    Location
    Jakarta, Indonesia
    Posts
    274
    Thanks
    3
    Thanked 9 Times in 9 Posts
    I have long 'suffered' from a similar problem when spell-checking in Indonesian - I rarely have optional hyphens in English - so I assumed it was a problem with the Indonesian language dictionary. Clearly it's a wider problem.

    I have 'Check spelling as you type' un-checked, so the "Automatically use suggestions from the spelling checker" you mention is dimmed. But anyway this should not affect spell-checking.

    I'd really like a work-around for this. It's a pain to have to skip all the optionally-hyphened words during the spell-check...

    Chris

  4. #4
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Quote Originally Posted by ChrisJakarta View Post
    I'd really like a work-around for this. It's a pain to have to skip all the optionally-hyphened words during the spell-check...

    Chris
    Hi Chris,

    Unfortunately, I could not recreate your issue. When I have check spelling (as you type) off and "Replace text as you type" off, then enter an optionally-hyphenated word and run spell-check, Word does not flag the optionally hyphenated words as misspelled. Perhaps someone else can recreate? I've tried this in both Word 2003 and 2007. Both versions are fully updated and I'm using the U.S. English version. That might explain the difference, too.

    However, you might try turning on Spell-check as you go, then explicitly turn off Replace text as you type, then turn off Spell-check. I've also found that it is sometimes helpful to close and open Word before testing on a new document. Or at least reset your current document.

    My morning's testing did find a discrepancy between the two versions that would affect the suggestion in previous post.

    If you uncheck the "Replace text as you type" in 2003 and run spell-check, the dialog will not offer any alternate spelling suggestions, even though the context menu will. See my graphic, below.

    This is not true for Word 2007, which will offer alternate suggestions in the dialog and in the context menu. However, if you use 2003 and rely on the spell-check dialog, my suggestion will make running it more onerous and less enticing...

    Kim
    Attached Images Attached Images

  5. #5
    Lounger
    Join Date
    Mar 2007
    Location
    Houston, Texas, USA
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Kim, you are outrageously AWESOME! I'm going to try this as soon as I can connect to the secretary's computer.

    Thanks!!

  6. #6
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Well thanks! My fingers are crossed. Post back and let us know if it works out, or if it doesn't.

    Best, Kim

  7. #7
    3 Star Lounger
    Join Date
    Sep 2001
    Location
    Jakarta, Indonesia
    Posts
    274
    Thanks
    3
    Thanked 9 Times in 9 Posts
    Quote Originally Posted by kmurdock View Post
    ...
    However, you might try turning on Spell-check as you go, then explicitly turn off Replace text as you type, then turn off Spell-check. I've also found that it is sometimes helpful to close and open Word before testing on a new document. Or at least reset your current document.
    ...
    Kim,

    Thanks for the idea - and please forgive delay in replying - I've only just got around to testing this. Sadly it did not correct the problem.

    As I noted previously, I guess this must be a problem with the Indonesian-language spell check.

    Chris

  8. #8
    3 Star Lounger
    Join Date
    Sep 2001
    Location
    Jakarta, Indonesia
    Posts
    274
    Thanks
    3
    Thanked 9 Times in 9 Posts
    Forgot to mention another frustration with this problem. That is that clicking the 'Ignore All' button does not work for words with optional hyphens. Thus I must click 'Ignore Once' in every case. Since the texts are usually fact sheets with many repeats, this gets a bit boring! But worse, it makes it much easier inadvertently to ignore real typos.

    Chris

  9. #9
    Lounger
    Join Date
    Mar 2007
    Location
    Houston, Texas, USA
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by kmurdock View Post
    Well thanks! My fingers are crossed. Post back and let us know if it works out, or if it doesn't.

    Best, Kim
    Hi Kim,

    Unfortunately, she still has the issue. That setting (Automatically use suggestions ...) was already deselected. I told her she will have to continue using the workaround of backspacing to make the correction.

    Thanks so much for your help.

  10. #10
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Quote Originally Posted by ATPWordPro View Post
    Unfortunately, she still has the issue.
    Oh, bummer! Not sure what this is about. I can't get it to not work. The only time I get the documen/document substitution is when I have that check box checked.

    There may be other switches to pull... but first things first. Is your secretary's program all patched up? I'm running Word 2003 SP3 and I regularly apply patches from MSFT.

    K

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •