Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Apr 2010
    Location
    Alabama
    Posts
    44
    Thanks
    1
    Thanked 2 Times in 2 Posts
    The icons for files associated with Firefox (.html and .htm) have reverted to a generic icon when displayed in Windows Explorer (see image below). If I change the association to Internet Explorer, then the IE icon is properly displayed.



    The icon for firefox.exe is properly displayed on the desktop. I have been using FireFox on this computer for over a year with no problems. When I click on an .html file, it still opens properly in FireFox.

    Recent actions to my computer are as follows:

    Install Adobe Photoshop Elements 9
    Install Adobe Premier Elements 9
    Install Secunia PSI 2.0
    Install this weeks patches to WIN7.

    OS: WIN7 Ultimate (64 bit)
    FF: version 3.6.13

    Any ideas what is causing this?

  2. #2
    Lounger
    Join Date
    Apr 2010
    Location
    Alabama
    Posts
    44
    Thanks
    1
    Thanked 2 Times in 2 Posts
    It seems that nobody on this board has experienced this problem or has a solution. Any suggestions of any other forums where I may pose this question?

    Thanks,
    Steve

  3. #3
    Lounger MaBelleMichelle's Avatar
    Join Date
    Jan 2011
    Location
    Imagine
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello, have you considered rebuilding your icon cache for Win 7? You can find instructions

    Rebuild Icon Cache
    Sont des mots qui vont très bien ensemble

  4. #4
    Lounger
    Join Date
    Apr 2010
    Location
    Alabama
    Posts
    44
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by MaBelleMichelle View Post
    Hello, have you considered rebuilding your icon cache for Win 7? You can find instructions
    Thanks for the suggestion - Yes I have deleted IconCache.db and then let the operating system rebuild it but that did not fix the problem.

    Something I failed to mention in my earlier post - I had also upgraded FireFox. Possibly the firefox upgrade caused the problem. For now I'll live with the problem since it is nothing but cosmetic. I'll see what happens at the next firefox upgrade.
    Last edited by Steve1951; 2011-01-20 at 14:36.

  5. #5
    Lounger MaBelleMichelle's Avatar
    Join Date
    Jan 2011
    Location
    Imagine
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Perhaps a system restore to a point before you noticed the difference.
    Sont des mots qui vont très bien ensemble

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    try deleting cookies

  7. #7
    Lounger
    Join Date
    Apr 2010
    Location
    Alabama
    Posts
    44
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Smile I found a fix for the problem.

    I found a fix for the problem. Something (possibly one of the recent installs) had added an Icon Handler for Firefox. In the registry I found registry key HKEY_CLASSES_ROOT\FirefoxHTML\ShellEx\IconHandler was set to {42042206-2D85-11D3-8CFF-005004838597}. I also found registry key HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\Def aultIcon was set to %1.

    Here is what I did to fix the problem:

    1. I deleted registry key HKEY_CLASSES_ROOT\FirefoxHTML\ShellEx\IconHandler (I completely deleted the key, not just set it to no value).

    2. I set registry key to HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\Def aultIcon to C:\Program Files (x86)\Mozilla Firefox\firefox.exe,1

    3. I changed the file association from Firefox to Internet Explorer and then from Internet Explorer back to Firefox.

    Now all is functioning properly.
    Last edited by Steve1951; 2011-01-21 at 22:37.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •