Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Jan 2001
    Location
    Chantilly, VA USA
    Posts
    54
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Personal Macro Workbook

    I recently got a a replacement computer. I am running WIN XP and Office 2007 as I was before. I had a number of macros stored in my personal macro workbook, and know (thought I knew) how to record macros, assign to buttons on the toolbar, etc.

    Ever since the upgrade I can't seem to get macros in Excel to work. When I try to record macros I get an error message "Personal Macro Workbook in the startup folder must stay open for recording."

    I've created Personal.XLSB in the folder documents and setting/ [username]/application data/microsoft/excel/ xlstart, and can confirm that it's there.

    What's am I missing here? What do I need to tweak to make macros work again?

    thanks

    Don

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,205
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Do you have an alternate startup location specified that isn't valid?

    p.s. you only need to start on thread.

    cheers, Paul

  3. #3
    Star Lounger
    Join Date
    Jan 2001
    Location
    Chantilly, VA USA
    Posts
    54
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Paul: I don't think so...I just checked and couldn't see whee to specify the start-up location. And sorry about the multiple posts, I'm still getting used to the new lounge format and may have hit Post a few more times than turned out to be necessary

    Don

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,205
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Tools > Options > General is where I'd expect to find the file locations.

    cheers, Paul

  5. #5
    Star Lounger
    Join Date
    Jan 2001
    Location
    Chantilly, VA USA
    Posts
    54
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I found the answer. Personal.xlsb had somehow been Disabled.

    This thread
    "Try clicking on the Office Button at the top left of the window. Then at the bottom of the pop-up window, under the recent documents list,
    there is a button for Excel options.....click that button. Then on the left, click on Add-in's. At the bottom of the Add-in page there
    is a "Manage" drop down. Select Disabled Items from the "Manage" drop down and hit GO. If Personal.xlsb appears there, enable it again and
    it will startup when Excel starts up."


    from here
    http://www.eggheadcafe.com/software/...xcel-2007.aspx

    Seems to have fixed the problem

    Regards, and thanks,

    Don

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •