Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Jan 2010
    Location
    Lake Villa,IL
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy "Print Drectory" nightmare

    Using XP Pro, SP3, all updated. Tried to create "Print Directory" feature using KB 321379.

    Backed up registry with a restore point. Followed the instructions. Something went awry and it did not work. Impatience, so I just restored the registry.

    Now I have a modified right-click menu and default double-click action on all folders to start a search. If I right click and go down the list to "Open", I can open folders.

    I want to remove "Search" and "Print Directory" Listings from the top of my right-click menu on my folders so the default again becomes "Open"..

    Added info: When I retrace the steps to add the "Print Directory" to remove them, the step in Control Panel/Folder Options said to select "File folder", "Advanced" and "Add" then put in printdir.bat. Now it will not let me remove printdir.bat or delete the whole "File folder" entry. I am stuck with it. I deleted the printdir.bat file itself but the option still appears. Probably have to edit the registry to get rid of it.
    Last edited by catmanbob; 2011-02-03 at 16:51. Reason: Added information
    Regards,
    Catmanbob

  2. #2
    5 Star Lounger st3333ve's Avatar
    Join Date
    May 2003
    Location
    Los Angeles, California, USA
    Posts
    705
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Ya, that's an infamous (and longstanding) Windows bug that will (sometimes) change the default action when you double-click a folder to something other than Open (e.g., Search) after you change File Types settings.

    Here's the Registry fix: Go to HKEY_CLASSES_ROOT\Directory\shell and change the (Default) value to "none".

    NOTE: This is the word "none" (without the quotation marks), rather than a blank value.

  3. #3
    New Lounger
    Join Date
    Jan 2010
    Location
    Lake Villa,IL
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the info. I made the change. Right click menu shows "none" at the top. In some cases, it still open the "Search" screen. I suspect I also need to reboot for it to fully take effect in all instances. Thanks again. BTW, I see yr in SOCAL. Two feet of snow drifting to six feet here with a wind chill this a.m. of minus 8.
    Regards,
    Catmanbob

  4. #4
    5 Star Lounger st3333ve's Avatar
    Join Date
    May 2003
    Location
    Los Angeles, California, USA
    Posts
    705
    Thanks
    0
    Thanked 2 Times in 2 Posts
    The right-click menu shouldn't show "none" at the top. Are you sure you didn't use quotation marks in the Registry? The Registry value I described should just be the word none -- without quotation marks.

  5. #5
    New Lounger
    Join Date
    Jan 2010
    Location
    Lake Villa,IL
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by st3333ve View Post
    The right-click menu shouldn't show "none" at the top. Are you sure you didn't use quotation marks in the Registry? The Registry value I described should just be the word none -- without quotation marks.
    --Tried regedit again, without quotes. It is working fine now. Thank you again.
    Catmanbob
    Regards,
    Catmanbob

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •