Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Marseilles
    Posts
    47
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Can't search contents of .docx files

    Hi,

    I'm running W7 x64, Office 2003 with the Word 2007 converter installed.

    Windows search doesn't search the content of .docx files. Anyone have a work-round? The same happens with Agent Ransack, so I'm assuming it's a W7 issue.

    If I save the docx file containing the searched-for word as a doc file, it locates it no problem.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,605
    Thanks
    2
    Thanked 619 Times in 554 Posts
    See if Microsoft Office 2010 Filter Pack helps. Be sure to download the 64-bit version.

    Joe

  3. #3
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    6,371
    Thanks
    206
    Thanked 829 Times in 762 Posts
    Marp,

    It seems to work on my Win 7 64 Bit system. See graphic. The first document contains the text in the search box.
    Attached Images Attached Images
    May the Forces of good computing be with you!

    RG

    VBA Rules!

    My Systems: Desktop Specs
    Laptop Specs


  4. #4
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    798
    Thanks
    3
    Thanked 28 Times in 26 Posts
    How long has Windows 7 bee installed? I recall that when I first installed it that it took a while (a few days) for the search service to index all of my files (including docx files).

    The other question is - where are you docx files located? I know that the docx files I have in Documents are indexed, but I have noticed that docx files I have in various other locations are not being indexed. If that is the case for you, you mighth ave ot turn on indexing for those other locations.

  5. #5
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    You may have to re-index your PC. Type index in the search box and choose Modify to select locations to index. I chose to index as much as I could. The initial index takes a while but subsequent do not take as long.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  6. #6
    Lounger
    Join Date
    Dec 2009
    Location
    Marseilles
    Posts
    47
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by joeperez View Post
    See if Microsoft Office 2010 Filter Pack helps. Be sure to download the 64-bit version.

    Joe
    Downloaded the pack and restarted the indexing from scratch. Did the trick, thanks!

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,605
    Thanks
    2
    Thanked 619 Times in 554 Posts
    Quote Originally Posted by Marp View Post
    Downloaded the pack and restarted the indexing from scratch. Did the trick, thanks!
    You're welcome. Glad you got it working. Thanks for posting back.

    Joe

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •