Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't change or save Word 2010 docs: Read Only

    I am currently working on a dual boot machine that boots to WinXP or Win 7. In Win XP, all my documents open correctly in Compatibility Mode - I can save and edit them without problems.

    In Win 7, however, all my .doc files open as "Read Only." I cannot save them. I have gone into the Trust Center and unchecked all the boxes in the "File Block Settings." There are, however, some settings such as "Word 2003 Binary Documents" and Templates and "Word 97 Binary Documents and Templates" that do not have a check box to uncheck for "Save" so there is nothing I can do about that. If I create a new Word document, however, with the .docx extension, it will then let me edit and save the document.

    I have gone into the "My Documents" directory and done the elaborate security thing where you take ownership of the files so that you can change them, but this hasn't helped. They still open as "Read Only." All these files are on my hard drive - they are not on a network. I have created all these .doc files and they are not accessed by anyone else. All the files are being opened in Word 2010 - the only difference is the OS I am opening them in.

    Any ideas?

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    6,158
    Thanks
    200
    Thanked 781 Times in 715 Posts
    Swanoir,

    Do the .doc files have macros {vba} attached? If so try going into the Trust Center and setting the folder they are in to a Trusted Location.
    May the Forces of good computing be with you!

    RG

    VBA Rules!

    My Systems: Desktop Specs
    Laptop Specs


  3. #3
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,268
    Thanks
    130
    Thanked 1,153 Times in 1,062 Posts
    Are the documents opening in Protected View?

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tried setting the folder to a Trusted Location. No love.

    The documents are not opening in Protected View. The are opening in Read Only with no other options. I have all the Protected view options shut off. Interestingly, we have Word 2010 at our clinic and the same documents open in Win 7 in Compatibility View. Not sure what that means.

  5. #5
    New Lounger
    Join Date
    Feb 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I use Read Only documents quite a bit for students. Apologies in advance if you have already tried this: Have you tried a simple Save As and change the file type to Word document?

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have tried Save As and changing the format type to Word document (for example, changing to .docx) but this creates a brand new document. I have over a thousand documents in one directory alone! So after doing this, I would need to go back into that directory and delete all the duplicate files, which is a lot of work. I would rather understand why this behavior is happening. Judging from my research on the Internet, I am not the only one having this problem. And, again, it does not seem to be happening on all my computers, which begs the question why is this happening at all.

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I think I have found a solution. It appears to have been a combination of the security/attribute system in Win 7 and the UAC. The "read only" problem is fairly wide spread in Vista and Win 7. According to Microsoft, "The Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder’s Properties dialog box.”

    However, it appears many things can occur to make Win 7 take the "read only" attribute more literally. Though I tried many ways to remove the "read only" attribute from data folders, including going into DOS, I was unsuccessful. And, in fact, the My Documents and My Music folders are still read only. The only work around I could find was to shut off the UAC completely. I can now freely edit my documents, as well as my music files in iTunes.

    For more information: http://itexpertvoice.com/home/fixing...-folder-blues/

  8. #8
    New Lounger
    Join Date
    Jan 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I also have this problem (and my machine is not dual-boot, I use Win 7 exclusively). It happens when I try to open a Word .doc file from its containing folder through Explorer. Double click on the file, and up pops the Read Only warning. However, if I right-click on the file and choose "Open" from the context menu, it opens with no problem! Why this works, I have no idea. But you may want to give it a try.

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Svansteen View Post
    I also have this problem (and my machine is not dual-boot, I use Win 7 exclusively). It happens when I try to open a Word .doc file from its containing folder through Explorer. Double click on the file, and up pops the Read Only warning. However, if I right-click on the file and choose "Open" from the context menu, it opens with no problem!
    Traditionally, Open was the default action and appeared in bold type on the right-click menu. On your right-click menu, is a different action bolded (i.e., set as the default action)?

  10. #10
    New Lounger
    Join Date
    Jan 2010
    Location
    Gloucester, Virginia, USA
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Fixed:

    I was having the same problem with Word 2010 after a clean reinstall of Windows 7. I could overwrite, move, and delete the file from within Windows Explorer, but couldn't do anything with it using Word. I couldn't even save any file to that location (My Documents) using Word. I checked the file and folder attributes using Windows Explorer, and nothing appeared as Read-Only. After other solutions posted on several forums did not work, I had the bright idea to open Windows Explorer in administrator mode, and lo and behold, my entire user folder was Read-Only. Unchecked the box, clicked apply, and it's all good now. I've found that "Run as Administrator" can fix a lot of problems, but for some reason I don't think about it until I've run myself ragged looking for solutions.


    Right-click on Windows Explorer
    Select "Run as Administrator"
    Click on "YES" in the User Account Control pop-up
    Navigate to the folder in question and right-click on it
    Uncheck the "Read-Only" block
    Click "Apply"


    Strangely, when I go back and look at the properties a second time, it shows up as Read-Only again, but Word saves normally. I'm not sure what the deal is with that, and it bothers me a bit, but at least it works.

  11. #11
    3 Star Lounger
    Join Date
    Apr 2012
    Posts
    237
    Thanks
    3
    Thanked 24 Times in 24 Posts
    Another thing to watch for, I've found that in Windows 7 Explorer, if I had the "Preview" window turned on, when I actually opened documents, they would be read only. Had to close either Explorer, or the Preview function in order to save changes.

  12. #12
    New Lounger
    Join Date
    Jul 2012
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts

    intermittent and undeletable

    I'm having the same issues as the original poster - I have 'saved as' docx and as this problem has only been around for me the last couple of weeks (despite having had this laptop set up for over a year) so thought I would just delete the old file but it won't let me. Despite having no word software or documents open at all, it tells me "word is currently using this file and it cannot be deleted".

    The 'read only' and 'compatibility mode' appear at the top of an open document, sometimes whether its a 97/03 or 2010 document, but not always and that's what's driving me crazy!

    Any other ideas cos I've tried everything in the list so far

  13. #13
    New Lounger
    Join Date
    Oct 2013
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    New operating system

    I have been having a similar problem with old Word files having changed from Win-XP to Win-8 and Word-XP to Word-2010.

    To fix the problem you (may) need to alter the folder/file attributes to turn off read-only mode ...

    BUT you may also need to change the permissions on the folders/files. If you have installed a new operating system your system is likely to consider that it has a new name (and even if the name is the same the GUID will be different). Therefore all the old permissions on your files will now refer to GUIDs which are not recognised by the new operating system (eg 'Account unknown (S-1-5-12......)').

    To fix this problem, start windows explorer using an administrator ID, find the folder which you are having problems with, right click on the folder name, click on the Properties menu item, select the Security tab, and then give your new Userid the permissions you need for that folder. This fixed it for me.

  14. #14
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,146
    Thanks
    203
    Thanked 207 Times in 199 Posts
    Quote Originally Posted by NickRob View Post
    I have been having a similar problem with old Word files having changed from Win-XP to Win-8 and Word-XP to Word-2010.

    To fix the problem you (may) need to alter the folder/file attributes to turn off read-only mode ...

    BUT you may also need to change the permissions on the folders/files. If you have installed a new operating system your system is likely to consider that it has a new name (and even if the name is the same the GUID will be different). Therefore all the old permissions on your files will now refer to GUIDs which are not recognised by the new operating system (eg 'Account unknown (S-1-5-12......)').

    To fix this problem, start windows explorer using an administrator ID, find the folder which you are having problems with, right click on the folder name, click on the Properties menu item, select the Security tab, and then give your new Userid the permissions you need for that folder. This fixed it for me.
    I would suggest temporarily giving your normal username administrator rights before doing the above. Then log in under your normal username and do the above.

    In this way, you will be able to handle all permissions issues while logged in as yourself.

    Then, when you are done, and you have reset your normal username back to limited rights, your normal username will retain all rights you acquired to the files in question.

    There are those occasions where, if you change file permissions on a file, but you weren't logged in as yourself while doing it, you won't completely achieve the desired result. The only way to guarantee that your normal username will always retain the rights that you are acquiring is to give full rights to your normal username, and then acquire the desired rights logged in under your normal username.
    Last edited by mrjimphelps; 2013-10-08 at 16:34.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •