Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Jun 2010
    Location
    Singapore
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts

    External Dell Monitor has no audio after wake up

    I have a Dell ST2410 24" HD monitor attached to my HP Laptop (Compaq Presario CQ45) by way of an HDMI cable supplied with the Dell. I use the audio ports on the Dell Monitor to provide audio to (great sounding) stereo speakers with subwoofer. After boot up, all is great, BUT ...
    When I put the PC to Sleep (rather than Shutdown) and I wake it up, the NVIDIA card (GeForce 9200M GS) sees the monitor as no longer connected and the audio is redirected to the (inferior) laptop speakers. I correct the problem by unplugging the HDMI cable, count to 3 (a sanity thing!) then reinsert and voila all is well again.

    Question please - is there a permanent fix?

  2. #2
    5 Star Lounger chowur's Avatar
    Join Date
    Mar 2010
    Location
    Indiana
    Posts
    804
    Thanks
    0
    Thanked 54 Times in 51 Posts
    I would start off by buying a new cable they are pretty cheap.The question is what type of OS are you running.In order to help you better.
    Problems cannot be solved by the same level of thinking that created them. -Albert Einsten

  3. #3
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    6,121
    Thanks
    160
    Thanked 609 Times in 557 Posts
    Windows 7:
    In advanced power management, ensure PCI express; "Link State Power Management" set to off.

  4. #4
    Lounger
    Join Date
    Jun 2010
    Location
    Singapore
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am running Windows 7 Home Edition

  5. #5
    Lounger
    Join Date
    Jun 2010
    Location
    Singapore
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have tried setting PCI express; "Link State Power Management" set to off, but unfortunately, still no go. (who would know to even look there - I am so impressed).

  6. #6
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    6,121
    Thanks
    160
    Thanked 609 Times in 557 Posts
    While the monitor is attached and fully functional
    See if you can go into devmgmt.msc & track down your audio output (monitor speekers) and check if there is some setting that will make it the default, do the same with the monitor...

    otherwise your looking at continuing to do what have have been doing to correct the issue.

  7. #7
    Lounger
    Join Date
    Jun 2010
    Location
    Singapore
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Clint - I have found that the Rank of the Installed Driver (this would presumably indicate if it is default) of the IDT High Definition Audio CODEC (i.e. the laptiop) is 00FF0001, whereas the NVIDIA HDMI Audio is given as 00FF2005, but there is no means in the devmgmt.msc to change that. I expect it might lie somewhere in the registry and to be honest, changing things there makes me a little bit nervous.
    Brian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •