Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Jan 2002
    Posts
    142
    Thanks
    0
    Thanked 0 Times in 0 Posts

    USB Hard Drive disconnects if not used

    I have a desktop unit with routers and 2 external WD hard drives connected to them. Unless accessed periodically (I don't have the time-frame down yet) one of the external hard drives becomes unavailable - without human intervention, on the same router, using a good cable. I see this when I open MY COMPUTER, see the drive letter, hear the XP USB disconnect sound, see the drive letter disappear, then, hear the XP USB connect sound, see AUTOPLAY, and, then see the drive letter appear. I have assigned drive letters and the same drive lette goes away and re-appears. My other WD USB does not do this. I have swapped routers, USB cables and gone through the hard drive TOOLS tab to see if anything look out of place or different. To my untrained eye all looks OK.
    Any ideas would be appreciated.
    Thanks in advance.

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts

    Question

    Nucthat1,

    If I understand your post correctly you have 2 USB External drives connected to your Router?
    Are the drives identical models?
    What router are you using?
    Have you accessed the router firmware via your browser to see if there are settings for the USB connected drives?
    Are you using any software that came with the router to assign drive letters to the drives?
    Have you tried connecting the drives directly to the computer to see if the same behavior exists?
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,203
    Thanks
    49
    Thanked 989 Times in 919 Posts
    Does the drive power down if not used?

    cheers, Paul

  4. #4
    New Lounger
    Join Date
    Feb 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    goto device manager and make sure that NO usb devices have a tick in 'power management' to say 'allow the computer to turn off this device to save power'..............

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •