Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Jun 2001
    Posts
    103
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Macros not running even though

    Has anybody ever had the problem that even though the macros are "enabled", they do not run at all?

    All the macros are available, but no running at all. If I press ALT+F11 and try to run from there, it goes to a macro and says the name is ambiguous. I change it and it goes to the next and I change it, etc. you get the picture, but it does not run any of the macros.

    Any ideas?

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    That message typically means that there is more than one macro in current scope, with the same name. This causes a compile error, and no macros will be able to run until the error is corrected.

    If you're changing the macro names so that they are different, and are still getting the error message, not sure why that would happen. Where are the macros located? Are they all in the same template? Is it possible that you have additional instances of the same macros also in scope somewhere else (for instance in an add-in?).

    If you have any add-ins loaded, try disabling them and then try again - does that make any difference?

    Gary

  3. #3
    2 Star Lounger
    Join Date
    Jun 2001
    Posts
    103
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you Gary. I will check a little later.

  4. #4
    2 Star Lounger
    Join Date
    Jun 2001
    Posts
    103
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I couldn't figure out what the problem was, but as I always repeat like a "mantra", backup, backup, backup, and I follow my own mantra, I copy and pasted all the macros back into the template, and it resolved the problem. I was not going to go through more than 200 macros just because of one. Thank you again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •