Results 1 to 7 of 7
  1. #1
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Toronto
    Posts
    100
    Thanks
    7
    Thanked 2 Times in 2 Posts

    keyboard has a mind of its own

    I've replaced my keyboard in hopes of solving this problem, but it persists even with my new one, so I assume that it must be some software issue. Now and again, the keyboard remaps several keys. Instead of a question mark, I get a French capital E with an accent aigue. The apostrophe alters slightly to something that looks like a slightly "off" apostrophe, something spell-checkers don't recognize it as an apostrophe. The double quote sometimes changes to something else. Most of the other keys function normally. I'm not completely sure whether this happens only when I'm composing an email, which is when I seem to notice it most often, or whether it also happens within other programs. I think I once tested it in Notepad when it went wonky, and it was also happening there. I read somewhere that you can reset your keyboard to default by holding Shift-Ctrl for 10-12 seconds. That eventually seems to work, but I have to try it over and over and over - quite annoying. I've had a look at Control Panel but nothing seems unusual there. I'm using Windows Seven with a desktop machine.

  2. #2
    Star Lounger
    Join Date
    Apr 2010
    Location
    fayetteville, nc
    Posts
    57
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Have you tried updating the keyboard, BIOS, chipset, and USB drivers? Seeing how it does it with both keyboards and it returns after resetting the keyboard these and the connector on the computer would be the most likely culprits.

  3. #3
    Silver Lounger
    Join Date
    Apr 2010
    Location
    Montréal
    Posts
    1,795
    Thanks
    33
    Thanked 52 Times in 51 Posts

    Lightbulb KB language.

    Hello TO.

    You are indeed captive of your KB. Easy to fix. I do this all the time as I need two languages on mine. The trick to flip them is the Ctrl Shift combo. Try this and see what result you get.

    But a fix is available, it seems that it is software in your case. Go to Control Panel -> Regions and Languages -> Keyboards and Languages tab -> then select the language that you need, more than likely after you click on "Change KB", English Canada (US) if you are really in TO.

    Next go to : Advanced Key Settings and make your selection if per chance you need to toggle your KB layout if you have two languages selected. Kid's play !

    Let me know if this is your solution. Have a great day. Jean.

  4. #4
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Toronto
    Posts
    100
    Thanks
    7
    Thanked 2 Times in 2 Posts
    Ctrl-Shift does something but, as I said above, I have to do it over and over until it resets to English (Can).

    One of the first things I did was to check Control Panel. However, I'm glad you referred me to it again. It has always been set to Default Input Language: English (Can). But under that, there was Installed Services: EN English Canada, and under that was Keyboard: Canadian Multilingual Standard. I suspect the problem was with the "multilingual" part of that, causing the confusion switching back and forth between English and French characters. I still don't understand why that was happening. I've always wondered whether as my fingers stumble around the keyboard maybe I hit Ctrl-Shift without realizing it - I doubt it, but it's possible - although it should have been much easier to reset back to English with another simple Ctrl-Shift, instead of all the key-pressing I had to do. Anyway, now I've changed the setting of Installed Services to U.S. That will probably fix things. (Maybe it's Microsoft's way of saying all we English Canadians are no different from Americans anyway? I respectfully disagree.)

  5. #5
    New Lounger
    Join Date
    Mar 2011
    Location
    New Westminster BC
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When I got my new Dell PC last fall with Windows 7 and Office 2010, the first thing I did, of course, was change everything to the Canadian settings. It was OK, until I tried to use Outlook 2010. My keyboard was doing exactly the same thing - all the time. After much research, I determined that it was stuck on the Canadian Multilingual setting and there was no way to convince it to use the US layout. The rest of Office had no problem, just Outlook. It wouldn't hot swap or anything, no matter what I had chosen in the Control Panel. I discovered that the registry is the problem. The Multilingual and US layout codes are both in there, and the Multilingual code was first. So it appears that Outlook queries the registry for the layout to use and just returned the first one found, not the one I had selected. I ended up editing the registry and changing the setting in Computer\HKEY_CURRENT_USER\Keyboard Layout\Preload\1, which had the code for the Multilingual layout 00011009, to the US layout code 00000409. I don't remember if I tried setting the (Default) value to 00000409 first, I just know changing 1 solved the problem. I don't have access to the Multilingual layout now, but I never use it anyway.

  6. #6
    Silver Lounger
    Join Date
    Apr 2010
    Location
    Montréal
    Posts
    1,795
    Thanks
    33
    Thanked 52 Times in 51 Posts
    Hello Lime06.
    You way of solving the language problem is a brute force solution. Good. Being in Montréal, see the é ?, I need two languages and I use the Ctrl-Shift key sequence. I would not want to have to go to the Registry any time that I wished to shift languages. This option is in Windows just for us lowly technical users. One has to find his way into Panel -> Regions and Languages and set them as needed/wished. It took all of 5 minutes to set and try, going back to Panel -> R&L a few times. Funny, but to get to the proper language for the Can-Eng, I had to use the US keyboard, as David in TO mentioned. The multi-Language gave me too many deviations that I did not want.
    Have a great Canuck day. Jean.

  7. #7
    Silver Lounger
    Join Date
    Apr 2010
    Location
    Montréal
    Posts
    1,795
    Thanks
    33
    Thanked 52 Times in 51 Posts
    TO in David, hello.

    The many hits required, would be due to too many languages setup. I only have two and then the Ctrl-Shift will flop one way then the other on a single click. Your many clicks are due to the cascading of one to the next one as per the many Language selections in Panel. Methinks. Jean.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •