Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Can't view one website (opendns.com)

    If I go to just about any page at www.opendns.com, the browser displays nothing and shows busy forever. This happens for multiple browsers (chrome & IE8) and multiple pages at opendns.com. This is from a new install of Windows 7, 64-bit.
    The page is apparently fetched OK, because I can right-click the blank screen and take a look at the source code. I can also see the code being fetched using wireshark.
    My local network is OK, since I can see the page from an XP system.
    I have found no other web sites that have problems. This one, for example...
    The most suspicious thing I did was to install VB6, clicking past two compatibility warnings. Perhaps some .dll got overwritten?
    sfc /verifyonly reports no problems.
    I'm looking for help understanding what the problem is. If I don't find anything to fix in the next couple days, I'll probably try a repair installation of W7.

  2. #2
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    Try opening it with Firefox with the NoScript addon installed. Or just turn off JavaScript in your browser. I have found that poorly written JavaScript can render a page completely useless (which I why I rely heavily of FireFox+NoScript).

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by cafed00d View Post
    Try opening it with Firefox with the NoScript addon installed...
    That's a nice thought. However, disabling javascript in Chrome options did not change the symptoms.

  4. #4
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi richw42, open the browser you want and set it as default from the start menu & clear everything i.e. in Firefox its on tools menu 'Clear Recent History' select everything, close FF.
    On start menu search box print cmd right click cmd.exe and run as administrator. print ipconfig /flushdns and hit enter. Reboot your PC.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  5. The Following User Says Thank You to Roderunner For This Useful Post:

    richw42 (2011-03-20)

  6. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Arkansas
    Posts
    14
    Thanks
    0
    Thanked 1 Time in 1 Post
    The recommendation that was given by Roderunner was what I would definitely try first, try to flush the dns buffer using the ipconfig /flushdns command. what can happen is that you might have "touched" a site with a bad dns entry. Remember that many DNS clients will cache the results of name resolutions requests. This is done so that the next time you go to that site, the page will load faster that second time and the mapping will allow it to load faster.
    flushing the dns can remove those bad caches and then allow you to display the web pagey you are wanting to see. Hope that helps out some.

  7. The Following User Says Thank You to BillSheets For This Useful Post:

    richw42 (2011-03-20)

  8. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Roderunner View Post
    Hi richw42, open the browser you want and set it as default from the start menu & clear everything i.e. in Firefox its on tools menu 'Clear Recent History' select everything, close FF.
    On start menu search box print cmd right click cmd.exe and run as administrator. print ipconfig /flushdns and hit enter. Reboot your PC.
    Thank you! That was the right answer, except that I had to do one more thing: Replace my DNS server. I manually selected 4.2.2.1 as my DNS server, did the above, and everything started working normally. Changed my DNS server back to the opendns servers, did the above, and it was broken again. I may be crazy here, but it seems like the opendns DNS servers are not compatible with the opendns.com web site!
    For those curious, the opendns servers I am using are 208.67.222.222 and 208.67.220.220
    I have not tried them one at a time. I think I'll just be happy with knowing that it apparently isn't my system's fault.

  9. #7
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Original Post by richw42
    Hi richw42, please explain how and where you entered the servers for Opendns.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  10. #8
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Roderunner View Post
    Hi richw42, please explain how and where you entered the servers for Opendns.
    I have a Linksys WRT54G which is my DHCP server. I configure the DNS servers there. Detailed instructions can be found at https://store.opendns.com/setup/
    To replace those servers with 4.2.2.1, I used Windows Control Panel/Network and Sharing Center/Local Area Connection/Properties/IPv4/Properties/Use the following DNS server addresses.

  11. #9
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi richw42, I suggest restoring your IPv4 settings to default settings. This is mine:-

    Attachment 27689

    You also need the OpenDns Updater. for Windows.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  12. #10
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Roderunner View Post
    Hi richw42, I suggest restoring your IPv4 settings to default settings. This is mine:-

    Attachment 27689

    You also need the OpenDns Updater. for Windows.
    The default setup is exactly what gives me trouble. It causes me to use the opendns DNS servers, and the my access to their site is broken. I could reconfigure my Linksys router to use the default DNS server from my ISP, but that kind of defeats the purpose of opendns.

  13. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I just did some debugging, and found the following:

    With DNS server 4.2.2.1, www-files.opendns.com resolves to 208.67.216.142, and everyone is happy.
    With DNS server 208.67.222.222 (which is one of the two opendns servers), www-files.opendns.com resolves to 204.194.237.142, and the web page does not display properly.
    It is interesting that after a delay of about 30 seconds, there are a bunch of java DNS requests, and then the opendns.com page is displayed without decorations.
    In the 4.2.2.1 case, the page displays correctly immediately with no java DNS requests.

  14. #12
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi richw42, as your in a different location than I am, download and run Namebench to find your fastest dns provider.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  15. #13
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Roderunner View Post
    Hi richw42, as your in a different location than I am, download and run Namebench to find your fastest dns provider.
    I don't want fast DNS, I want DNS with the features supplied by opendns.

  16. #14
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi it was to see how they compared to the DNS servers in my area. OpenDNS is fastest in mine. Post result if you use it please.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  17. #15
    New Lounger
    Join Date
    Dec 2009
    Location
    Everett, Washington, USA
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Roderunner View Post
    Hi richw42, as your in a different location than I am, download and run Namebench to find your fastest dns provider.
    Well, I'm not going to type in everything. opendns came in 1st and 3rd, at 172 and 186 mSec. Second was qwest 205.171.3.65, and fourth google 8.8.8.8

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •