Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Crewe,Cheshire,England
    Posts
    12
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Unhappy Word 2007 VBA errors

    I use Word 2007 and have just started having the following problems:
    When I try to launch the Visual Basic Editor from the Developer Tab nothing happens.
    If I access my list of Macros,again from the Developer Tab, my list of macros appears but if I try to edit any macro I get the following error message:
    "Unexpected Error Quitting". Pressing the Help button on the message box is not very helpfull it just says "an unexpected error occurred". On pressing the OK button on the message box the following error message box appears "Out of Memory". The help button here produces a lot of suggestions, but I don't understand what they mean.
    I can still run those Macros which are assigned to the quick launch bar.
    If anyone can offer any advice I would be extreemly obliged
    RavenSteve

  2. #2
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Sydney, Australia, New South Wales, Australia
    Posts
    251
    Thanks
    0
    Thanked 4 Times in 4 Posts
    I'm guessing that you previously had no trouble opening the macros?
    Sound like they may have been corrupted.
    Can you get at editing them from Alt-F8 edit?

  3. The Following User Says Thank You to peterl For This Useful Post:

    RavenSteve (2011-03-24)

  4. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Crewe,Cheshire,England
    Posts
    12
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Thanks. I have in the past had no trouble opening the macros.
    No I can't get at them from Alt-F8
    RavenSteve

  5. #4
    3 Star Lounger
    Join Date
    Apr 2001
    Location
    Levin, Manawatu-Wanganui, New Zealand
    Posts
    324
    Thanks
    9
    Thanked 28 Times in 26 Posts
    Hi
    Just recently I had unexplained issues with Word2010. A new normal template resolved something. I do not know what it fixed but the issues went away.

    You could try this as a last resort
    Locate and rename normal.dot?
    Close and restart Word.

    Renaming your current normal.dot? at least preserves any customisations you have there and you are able to retrieve them.

    Good luck
    G

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •