Results 1 to 5 of 5

Thread: Modify file

  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Louisville Ky
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Modify file

    Win7 home. Navigate to file. Open with notepad. Change one digit in the file. At this point I am unable to change the original file to reflect the change.

    Any attempt to update the original file results in "access denied" from notepad The file is "init.cfg". Thanks. Fred

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts
    What is the full path of this problem file?

    If in the system area and is a "Protected" file then you should NOT be changing it.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    Also check the properties of the init.cfg file and make sure that the read-only flag is not set.

    If the file is in a "protected" directory, and you need to change it, you need to run notepad as an administrator (right-click Notepad in the Start menu and select "Run as administrator"). Of course the warning DaveA gave still applies - don't do this unless you are absolutely sure you won't be messing anything up.

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Louisville Ky
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Edit "init.cfg" in folder Cryostasis\Data\Scripts\ and
    find the line "d.consoleh = 0".
    Replace 0 to 1 (d.consoleh = 1).
    Use ~ in Menu .
    This is what I was doing. Path is My computer C:\programfilesx64\1C\cryostatis\data\scripts. I have changed the console from "0" to "1". Now the question is how to apply the change to the init.cfg file. So far I have had no luck with this.

    Any save or saveas says I can't save the file here so how about in documents and I say yes. Any attempt to copy the new file to the original and notepad says access denied. This was not a problem in XP. Thanks again. Fred.

  5. #5
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    The problem is that you are editing a file in Program Files (x86) and that is a protected directory in Vista and Win 7. Unless you start Notepad with the "Run as administrator" option as I indicated, and then open the init.cfg file from within Notepad, you will not be able to change it. You other option is to first disable UAC, but that usually is not advisable (though on Vista doing so is almost required due to file shadowing issues that can bite you).

    Also, you still never mentioned whether the file was marked as read-only. If it is, you will also need to turn off that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •