Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts

    Opening PDF files in Internet Explorer 9

    Whenever I open a PDF file in IE 9, I get a prompt as to whether I *really* want to open it.

    Is there a way to turn the prompt off and just have it open PDF files?

    Regards,
    Chuck Billow
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    5 Star Lounger chowur's Avatar
    Join Date
    Mar 2010
    Location
    Indiana
    Posts
    804
    Thanks
    0
    Thanked 54 Times in 51 Posts
    When you have IE9 open.Go to,Tools,Internet Options,Click on the,Program Tab.You will see Internet program @ the bottom.Click on,Set Programs.This will open a different page.You will see a choice on what you need to do.
    Problems cannot be solved by the same level of thinking that created them. -Albert Einsten

  4. #3
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    No, if I'm understanding you, the file association is already set, and is correct. It's something in the security settings I think, since it is a safety warning I am receiving.

    Chuck
    Attached Images Attached Images
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  5. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    You may have set IE to prompt you before running ActiveX controls. This is one of many possible settings for the Internet Zone. If you didn't customize and instead selected a level (e.g., High), it could be a feature of that level.

  6. #5
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Jefferson, I went back, set security to default (medium-high) and then enabled mixed content. It still prompts me. Gr-r-r-r-r.
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  7. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by CWBillow View Post
    Jefferson, I went back, set security to default (medium-high) and then enabled mixed content. It still prompts me. Gr-r-r-r-r.
    Not sure what mixed content is. There should be specific settings for ActiveX controls.

    You want to be very cautious with the settings related to downloading/installing new controls, but you could enable sites to run your existing controls. If you don't want to allow access for all sites in the Internet zone, you could instead add the specific site to your Trusted Sites list.

    At least as of IE8, Microsoft doesn't break down the settings by control. In other words, you can't say Enable PDF but Prompt for Flash (etc.). Maybe some day!

  8. #7
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Quote Originally Posted by jscher2000 View Post
    Not sure what mixed content is. There should be specific settings for ActiveX controls.

    You want to be very cautious with the settings related to downloading/installing new controls, but you could enable sites to run your existing controls. If you don't want to allow access for all sites in the Internet zone, you could instead add the specific site to your Trusted Sites list.

    At least as of IE8, Microsoft doesn't break down the settings by control. In other words, you can't say Enable PDF but Prompt for Flash (etc.). Maybe some day!
    The "Mixed Content" setting is one the was spawned out of need some time back, and it hasn't caused my any problems at all. I always had that one set to "allow", and never, till IE 9, had this issue with PDF files.

    Well pooh!
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  9. #8
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 931 Times in 852 Posts
    I'm wondering if the PDF app has been corrupted. I switched to PDF-Xchange Viewer quite some time ago and am very pleased with it. Mine works very well with IE 9 (default mode):

    Here is how my Active X controls look on my PC.

    Security Settings 1.jpgSecurity Settings 2.jpgSecurity Settings 3.jpg

    Sorry, it took 3 attachments to show all the Active X stuff!
    Last edited by Medico; 2011-04-24 at 06:30.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  10. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by CWBillow View Post
    The "Mixed Content" setting is one the was spawned out of need some time back, and it hasn't caused my any problems at all. I always had that one set to "allow", and never, till IE 9, had this issue with PDF files.
    I'm still not sure what "mixed" means, but since the infobar is very specific about ActiveX controls and scripting, what happens if you try Ted's settings? I think those settings will store your Allow/Disallow decision on a site-by-site basis so you only get the infobar once. However, I haven't tested myself.

    (I personally open all PDFs externally in Adobe Reader for historical reasons (browser stability in older versions of IE) and because I prefer the full control offered by Reader. This is accomplished using Adobe Reader's Edit > Preferences dialog, Internet settings, uncheck "Display PDFs in browser".)
    Last edited by jscher2000; 2011-04-24 at 12:40. Reason: Upon futher review.

  11. #10
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Quote Originally Posted by jscher2000 View Post
    I'm still not sure what "mixed" means, but since the infobar is very specific about ActiveX controls and scripting, what happens if you try Ted's settings? I think those settings will store your Allow/Disallow decision on a site-by-site basis so you only get the infobar once. However, I haven't tested myself.

    (I personally open all PDFs externally in Adobe Reader for historical reasons (browser stability in older versions of IE) and because I prefer the full control offered by Reader. This is accomplished using Adobe Reader's Edit > Preferences dialog, Internet settings, uncheck "Display PDFs in browser".)
    The "Mixed Content" choice is discussed by Microsoft here:

    http://msdn.microsoft.com/en-us/libr...(v=vs.85).aspx

    which in part states

    "the mixed content warning occurs when a Web developer references an unsecure (http) resource within a secure (https) page. Such references create vulnerabilities that put the privacy and integrity of the otherwise secure page at risk, because the unsecure content could be modified in transit."

    I have had a couple professional sites that required that "allow" in order for access to "work."

    In a perfect world, if a all the coding were done in a prudent manner, perhaps those less informed such as myself wouldn't need such a choice. But coding is far from either standardized or perfect, as we all know.

    In many ways Jefferson, you're right -- just use an external viewer. Looking for the resolution of "interal display" is in part because when one thing goes wrong, that usually is a precursor to more on the way!

    Chuck
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  12. #11
    New Lounger
    Join Date
    Jun 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by CWBillow View Post
    Whenever I open a PDF file in IE 9, I get a prompt as to whether I *really* want to open it.

    Is there a way to turn the prompt off and just have it open PDF files?

    Regards,
    Chuck Billow
    Did you ever resolve this issue? I am having the same problem.

  13. #12
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Nope.

    Chuck
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  14. #13
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,554
    Thanks
    2
    Thanked 614 Times in 550 Posts
    Is this on one site or all sites?

    Can you post one or more screenshots of your IE settings?

    Joe

  15. #14
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Joe, I just tried it again [IE 8 and a PDF off my own drive] and the control pops up.

    Chuck
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  16. #15
    Platinum Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    5,638
    Thanks
    53
    Thanked 9 Times in 8 Posts
    Joe, which one(s) do you want?

    Chuck
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •