Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    british columbia, canada
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Automark in Word 2010 - poblems

    Good morning, all.

    I am trying to put an index in my document (500 pages more or less). However, I have some problems.

    1. The index should include expressions like @param and @throws and == and <= in the index. I have included them in my AutoMark file (and they are most definitely in the main document) but they do not appear in the index when it is generated. The expression -= does appear in the index while += does not. Yes, the document is about Java programming.

    2. After I mark my index entries, the XE codes remain visible in my document whether or not I click Show/Hide formatting characters. All formatting characters appear or disappear as expected except for the XE codes. When I Print Preview I see the document without the XE codes appearing. How do I hide the XE codes? Having the codes visible makes me wonder about the accuracy of the index.

    3. In a few places the index appears to show what I can only describe as Chinese characters in front of some of the page numbers. Any idea why is this so? This happens about 10 times in an index that is about 20 pages long. I can't go to the pages in question due to the XE codes appearing. (See problem 2).

  2. #2
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Hi rgee,

    I have Word 2010 and gave this a try.

    In regard to item 1: I created two sentences, one with the terms @param and @throws in it and one with the terms "==" and <=" in it. I then selected each term and clicked Mark Entry on the References tab. I Inserted an Index and all terms appeared in that Index. However, I too discovered a glitch with the == and <= terms. Even though they appeared in my Index, the page number was not right justified. I fixed this, however, by simply inserting a tab between the term and the page number. See below. Unfortunately, the tab disappeared when I updated the Index. Still...

    In regard to item 2: in my document, each XE field disappears when I use Show/Hide. Again, see below. The XE field is formatted with hidden text (note the tiny dotted underline below the marked term), and should respond to the Show/Hide clicks.

    Go to File > Options > Display and check the settings regarding Show/Hide. Put a check in the box next to "Show all formatting marks" if it isn't already there. Does that change anything?

    If the tiny dotted lines don't appear at all, is it possible the hidden attribute was removed from the fields somehow?

    If any of this works, we'll be able to better diagnose item 3: the Chinese characters.

    Best, Kim
    Attached Images Attached Images

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    british columbia, canada
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks, Kim.

    You're right that you can use @param, for example, if you use Mark Entry on the References tab. You cannot put it in an automark file, though, and have it marked. I have to wonder why.

    Re the display of XE codes, Both Hidden text and Show all formatting were checked. I unchecked Hidden text and that problem is solved.

    Now it's on to building the index. Struggling with automark files is the next big problem - I wish I could say include <this word> when its style is <this style> and don't include it when its style is <that style>.


    Rick

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    british columbia, canada
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The AutoMark file resulted in many XE field codes, some wanted, some unwanted. For example, since the subject is Java, reserved words like short, long, if, while, and return are all marked for the index. I only wanted some of the occurrences in the index but when I deleted the unwanted occurrences, Word 2010 ate large chunks of my file.

    I'm not using AutoMark any more!!

  5. #5
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Rick, I have to admit it didn't register that you were using an AutoMark file. Sorry. I've had greater and lesser success with them, too. Mostly the latter. You're absolutely right that those symbols seem to mean something more than just the plain text of the terms. Microsoft has this kb article about how you can't use an apostrophe in a concordance file. Perhaps there's something to learn from it? Their workaround relies on a search/replace technique that may prove too fussy given all the forbidden symbols you need to include in your Index.

    I had complete success with the "Mark All" button on the Mark Index Entry dialog. Not only did it mark each of the terms accurately, but the index didn't have any of the formatting issues to which I referred in my previous post. Still, it requires working your way through your document and marking (at least the first instance of a term) by hand.

    A concordance file is probably an easier venue for checking for omissions than scanning through the source document, but at least manually coding the Index worked (for me). Given MSFT's workaround, it might even be faster?

    Added: And now it sounds as if your AutoMark file might be booby-trapped!?! Or haunted. Your experience would put me off them, too.

    Does an Index whiz out there have better advice?

    Best, Kim
    Last edited by kmurdock; 2011-05-28 at 10:34.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •