Results 1 to 2 of 2
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    San Francisco, California, USA
    Posts
    357
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Sharepoint default content type

    Hi all,

    I'm trying to work with sharepoint (SS2007), but of course I have no resources to do so, so please forgive me if this is a strange question.

    I have a library with two content types in it, Document and Link to Document. I need to have both of these content types in the library, because sometimes we need to have a document available to people in a particular library but we don't want to duplicate the actual document, so we link to the document in a different library. However, most changes to the library involve uploading documents, so I set Document as the Default Content Type. BUT if I go to upload a document to the library, I get two screens: the first screen allows me to select and upload the document, the next screen is an Edit Item screen where I have to specify whether I've uploaded a Link to Document or a Document before it appears in the library.

    Despite having selected Document as the default for the library, and despite Link to Document being an illogical thing to *upload* into a library, and despite the illogical alphabetical order of it all, and despite Document being the first choice in the list, Link to Document *always* appears as the item default in the drop down box. Users are forced to change the drop down when they upload a document.

    Is there any way to fix this? Selecting the option to not have Link to Document on the New button has no effect. I don't see any other controls for specifying what appears on the Edit Item screen (or for making that edit item screen go away).

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,609
    Thanks
    2
    Thanked 623 Times in 557 Posts
    I believe you always get the edit item screen when you upload a document. The default content type is just the one that will show up first in the drop down in the edit screen. I don't know of any way around this.

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •