Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Thanked 0 Times in 0 Posts

    hosts file problem

    I have another problem.

    I had omitted to add the Hosts file when redoing my pc and just now did it and am having problems with it. I use HostsMan and Host Toggle.

    HostsMan updates from:

    MVPS Hosts
    hp Hosts
    hp Hosts (partial)
    hp Hosts (Ad and tracking)
    Peter Lowe's adServers List

    When I go to the host file and try to disable it I get one of these messages:

    "File in use
    The action can't be completed because the file is open in Cryptographic Services"

    Another program is using Hosts file.
    Try again later."

    Other times I also am getting a message that says that the hosts file cannot be disabled when there is a file already called I go in and delete that file, but as soon as I hit disable again it reapears and the same message comes up.

    Also, I cannot get online with the hosts file on the pc now. It shows that it is connected to the router but it will not connect to the internet. I had to go in in safe mode to delete the host file so it would go online.

    I have the following security installed and did not see any that are locking the hosts

    Avast anti virus
    Spyware Blaster
    Windows Firewall

    OS is Windows 7 ultimate 64 bit and it is a wireless connection

    What can I do o get online?

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Silicon Valley, USA
    Thanked 93 Times in 89 Posts
    So you can browse normally if the hosts file is empty or just contains the default localhost line?

    But you can't if it is populated from a bunch of lists created by other people?

    Why not just use alternate methods to deal with those sites, such as blocking their cookies or adding them to Restricted Sites (IE) or not allowing them in NoScript (Firefox), etc.

  3. #3
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Thanked 215 Times in 182 Posts
    Hi ninajb, have you read this. From Here.
    Editors Note: in most cases a large HOSTS file (over 135 kb) tends to slow down the machine.

    To resolve this issue (manually) open the "Services Editor"

    Start | Run (type) "services.msc" (no quotes)
    Scroll down to "DNS Client", Right-click and select: Properties - click Stop
    Click the drop-down arrow for "Startup type"
    Select: Manual (recommended) or Disabled click Apply/Ok and restart. [more info]

    When set to Manual you can see that the above "Service" is not needed (after a little browsing - when set to Manual) by opening the Services Editor again, scroll down to DNS Client and check the "Status" column. It should be blank, if it was needed it would show "Started" in that column. There are several Utilities that can reset the DNS Client for you ... [more info]

    Editors Note: The above instructions are intended for a single (home-user) PC. If your machine is part of a "Domain", check with your IT Dept. before applying this work-around. This especially applies to Laptop users who travel or bring their work machines home. Make sure to reset the Service (if needed) prior to connecting (reboot required) to your work Domain ...

    Important! If you are using Network Discovery then the DNS Client service is required and should not be set to either Manual or Disabled.

    Possible Workaround for using the MVPS HOSTS file and leaving the DNS Client service enabled (set to: Automatic)

    If you find after a period of time that your browser seems sluggish with the DNS Client service enabled you can manually flush the DNS cache
    Close all browser windows ... open a "Command Prompt" from the Start Menu > All Programs > Accessories > Command Prompt
    (type) ipconfig /flushdns (press Enter) Then close the Command Prompt ...

    A better Win7/Vista workaround would be to add two Registry entries to control the amount of time the DNS cache is saved.

    Flush the existing DNS cache (see above)
    Start > Run (type) regedit
    Navigate to the following location:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Dnscache\Parameters
    Click Edit > New > DWORD Value (type) MaxCacheTtl
    Click Edit > New > DWORD Value (type) MaxNegativeCacheTtl
    Next right-click on the MaxCacheTtl entry (right pane) and select: Modify and change the value to 1
    The MaxNegativeCacheTtl entry should already have a value of 0 (leave it that way - see screenshot)
    Close Regedit and reboot ...
    As usual you should always backup your Registry before editing ... see Regedit Help under "Exporting Registry files"

    JBF sends along this Tip: IPCOP running a DHCP server needs the DNS Client enabled to function.
    O wad some Power the giftie gie us, to see oursels as ithers see us!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts