Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    USA
    Posts
    19
    Thanks
    1
    Thanked 1 Time in 1 Post

    Angry HighPoint Rocket 620 Drives show as External not Internal Drives - Ideas?

    All ... I am looking for ideas as to why my HighPoint Rocket 620 JBOD SATA card shows the drive connected to it as "external." That is the disk shows up in the “Safely Remove Hardware and Eject Media” dialog. The drive works fine … I just want it to show as an internal drive.

    Is there a way to make the disks show as “internal” like the other drives connected to the motherboard SATA connections … so that it doesn’t show in the “Safely Remove Hardware and Eject Media” dialog?

    I am in touch with HighPoint and they indicate that they have never seen this before … helpful!

    I blew the firmware at HighPoint's request. No change. I connected a completely different, older drive and it also showed as “external.” Device Manager shows everything is good … but I am not sure which driver I am looking for … I thought that there was Marvel 91xx driver … but I can’t see it now.

    Does anyone have some suggestions as to what settings can I check/change that could affect this behavior?

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,191
    Thanks
    48
    Thanked 985 Times in 915 Posts
    If the controller is a secondary controller then Windows may treat it as external. You could try disabling the primary controller in the BIOS?

    cheers, Paul

    p.s. How do you get to be Aussie if you are in the states? ;-))

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    USA
    Posts
    19
    Thanks
    1
    Thanked 1 Time in 1 Post

    HighPoint 620 still showing drives as "Removable" ... "External"

    Paul,

    Thanks for the reply. I am originally Australian ... but now a US Citizen :-)

    I don't want to disable the primary controller ... it is working fine ... and I still need it. I was looking to add SATA ports because my Motherboard ran out ... so I added the Rocket 620.

    So I tried a lot of stuff (an I am working with HighPoint ... but I am getting the impression that they are out of ideas). So I've tried:
    1) Original firmware card showed the drive as "removable". Installation instructions show that no software is required to be installed with Windows 7 Pro. No driver installation. Card seems to work except for making the drive “removable.”
    2) Flashed card (to an older version that HighPoint suggested/supplied – and no I don't have the latest version???)
    3) Card didn't show up in Device Manager (HighPoint said that they didn't expect it to show in the Device Manager???) – so, in desperation, I found a Marvell 93xx driver and installed it. Card shows up. It has a setting for "easy removal" which I equate to "external" ... but changing it didn't do anything.
    4) The disk itself is set for "best performance" not "easy removal" ... but changing it didn't do anything.
    5) A different/older SATA drive also shows up as "removable" ... so it is not the drive.

    I am pretty much out of ideas …

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •