Results 1 to 7 of 7
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Calgary, Alberta, Canada
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Discussion forum troubles

    I reviewed the recent discussion here and found some helpful suggestions on managing a discussion forum, but now I have a specific problem.

    Basically, the posts that have been made do not show up in the Table of Contents. When you do a search, the posts exist. To see what I mean, go to my site - nothing in the TOC, but do a search for "indoor" and the posts show up. Help!

  2. #2
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Re: Discussion forum troubles

    Can you tell us more? Version of FrontPage? What web server is serving up your site? Does it use FrontPage Server Extensions?
    Another thing to check out, (it bugs me that FP does this) if you logically order your discussion into sub folders (just checking your URL here - maybe this is what you've done) the FP components won't process properly. Try moving your discussion files up to the root of your web. Messy, but apparently the way FP likes it.
    Just off the top
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Calgary, Alberta, Canada
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Discussion forum troubles

    Sorry - FrontPage 2000, commercial host with FrontPage extensions installed. The discussion forum is located in a subfolder located in a subweb to make things more complicated. The reason I've organized it this way is that first, the PFHC subweb has a separate theme from the main web. I made discussion forum, which it part of the PFHC subweb, a subfolder instead of a subweb because I thought I wouldn't be able to have a sub-sub web. Am I correct?

  4. #4
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Re: Discussion forum troubles

    Yah, you are correct about the no sub sub web.
    But if 2 themes per web is what you are after.
    Take a look in Folder view, highlight the group of pages you want to have a unique theme and select Format, Theme. You'll note you can apply a theme to the pages you have selected.
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

  5. #5
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Calgary, Alberta, Canada
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Discussion forum troubles

    Ok. I'm moving the discussion folder out of the subweb and into the root web, and I've successfully applied the proper theme to the discussion folder. Is the right organization structure H:root webdiscussion folder? Will that take care of the processing of the discussion files?

  6. #6
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Re: Discussion forum troubles

    test it, but if it doesn't work - then you'll need to go to an even messier structure - moving your main discussion pages up to the root.
    but you are leaving the _disc folder and contents in place?

    I've attached a GIF of FP, so that we are clear on what I'm talking about. You'll note the _disc folder; FP creates this automatically and uses it to store the include information. You'll notice all the regular discussion files are right at the root of the web - (discovering where I can get away with moving them to is one of those things I've been meaning to play with, but havent had time for).
    Attached Images Attached Images
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

  7. #7
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Calgary, Alberta, Canada
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Discussion forum troubles

    Thanks so much for the help - full marks for the .jpeg which really helped me understand exactly where the files should be located. It took me a few tries and I lost the initial posts that I had placed up there (luckily I had backed them up in a .txt file) but everything's working great now. Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •