Results 1 to 6 of 6
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    Kennesaw, GA
    Posts
    67
    Thanks
    2
    Thanked 1 Time in 1 Post

    Slow win 7 explorer search

    Maybe search is not the right term here, but often when I go to look at a network drive I get a very long search with the green bar slowly crawling across the top of the screen in the address bar before the folder list comes up. I do not understand what causes this to be so slow. The folders are on a Home Server and physically it is sitting right next to this computer and connected to the same network switch. By contrast, my wife's win7 system upstairs sees all the folders almost instantly all the time and it goes thru two switches before reaching the server. Both systems are relatively new with Win 7 Home Premium X64 with 6gb memory and TB hard drives. The network shares are all mapped and used frequently. I do not understand why my computer is slow and hers is fast. Once I get a good folder list the system will continue to find things fast, but when I come back the hours later or the next day / morning it is often very slow to find everything again. I suspect I may have turned some search / indexing option off without realizing what it does. Got any ideas? Thanks

  2. #2
    Star Lounger
    Join Date
    Apr 2010
    Location
    fayetteville, nc
    Posts
    57
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Try going into folder options, clicking the "View" tab, and unchecking "Automatically search for network folders and printers".

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,579
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Have you checked the power management options?

    Also, "Automatically search for network folders and printers" is not available in the Windows 7 Explorer options.

    Joe

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Location
    Kennesaw, GA
    Posts
    67
    Thanks
    2
    Thanked 1 Time in 1 Post
    I have the computer on balanced with never sleep and turn off display after 2 minutes. I seldom ever power off this computer. Even if I go away for a few days I leave it on so I can access it remotely. I also do not reboot except when Win update requires it or I think the system needs to be rebooted after some changes I have made or software I have installed. I don't do anything different on this computer than I do with my wife's computer and I do ALL the maintenance, she is a user only and not technically attuned.

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,579
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Check the details of your power management, under PCI Express try setting Link State Power Management to "Off".

    Joe

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    hobart, tasmania, australia
    Posts
    21
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I get the same thing but on local explorer searches as well as networked. Can be very frustrating waiting miniutes for what should be seconds. I'm guessing it might be analysing the files under the folder you've selected?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •