Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Turn off Automatically Update Document Styles (Office 2000 SR1)

    Afternoon all. Question for you.

    Here's the situation. I have created a customized normal.dot for our Win2K/Word2K users, specifying default styles and etc. I create a new document and apply a List Bullet style. At this point I save the
    document. Then I modify the List Bullet style (changing font, bullet style, whatever...it doesn't matter) and save the document again. Then I close the document. When I reopen the document, it does not reflect the modified styles.

    I get the same behaviour regardless of the style I modify (in other words, this isn't related to the style itself).

    My question is...what is going on? We are also running MacroSuite, but I have eliminated that as the cause of the problem; the behaviour is the same without MacroSuite integration. I also removed our firm startup template, and that is related to the problem either. However, if I delete my custom normal.dot, the scenario described above works correctly and the style modifications are saved with the new document.

    Any thoughts? At all? Please? This normal.dot is based on the normal.dot we used for our Word 97 clients, and we had no problems with this. I feel like I'm losing my mind. I'm really trying to find out how to programmatically turn that option OFF for ALL documents by default.

    Thanks in advance for any assistance...

    klyjen

  2. #2
    JustCallMeAl
    Guest

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Somewhere under Tools, Templates and Addins (this is the menu choices for Word 97, so you may have to look around a bit), is there a checkmark in the box to Automatically update document styles? It sounds like there is one. Remove it and see if your problem continues.

  3. #3
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hi klyjen:

    Gary Frieder wrote a macro to remove automatically update from all styles. It is:

    Macro: RemoveAutomaticallyUpdate
    Sub RemoveAutomaticallyUpdate()
    Dim aSty As Style
    For Each aSty In ActiveDocument.Styles
    If aSty.Type = wdStyleTypeParagraph Then
    aSty.AutomaticallyUpdate = False
    End If
    Next aSty
    End Sub

    There is an odd side-effect to running this macro: it will cause all of the styles (including built-in style) to appear in the styles pull-down list - it's kind of like Word considers all these styles now "in-use" since the macro has interacted with and changed each of them.

    If the desired outcome is to remove the "automatically update" property from just selected styles, but while avoiding the odd side-effect above, it would be pretty easy to get the macro to only change the setting for specific styles such as the TOC ones.

    If you're not having this problem with the default normal.dot, could it be an Auto macro that you've included with your custom template that's causing the problem. I assume that you're modifying the style itself & not merely adding direct formatting to it.

    Hope this helps.

  4. #4
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Argh. I'm sorry...I copied/pasted that post, and clearly got the wrong part although I remembered it in the subject line....but it doesn't seem like I can edit the post...?? In any event...

    Yes, that check-mark is checked. For every new document. I have tried a couple of different vb coding tricks to attempt to turn it OFF for every new document, but I can't seem to control it. What I'd really like to find out is how I can ensure that this setting is turned off for each new document.

    Thanks again, and I apologize for the confusion...

    klyjen

  5. #5
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hi Phil.

    Actually, it isn't that I want to remove "automatically update" from any given style. The problem is (and see my response to JustCallMeAl) that the Automatically Update Document Styles (under Tools|Templates and Addins) is automatically turned ON, which means any changes I've made to styles in a particular document are lost once the document is re-opened (my original scenario). Obviously, we can turn this off on a case by case basis, but I really want to set it so that it doesn't DEFAULT to the "on" position.

    However, your macro may come in useful somewhere else, so I'll keep a copy...thanks!

    Jen

  6. #6
    JustCallMeAl
    Guest

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Let me summarize what I think you are saying.

    You have a situation where every time you create a new document the Automatically Update Document Styles under Tools, Templates and Addins has the check mark in the box. And this happens for every new document you create.

    Is the above correct?

    I have never heard of that happening.

    Sorry, but I am out of ideas.

  7. #7
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hey again Al. Yup, that's exactly the situation. If you think of anything, let me know...

  8. #8
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    The code to turn this off looks like

    ActiveDocument.UpdateStylesOnOpen = False

    Normally I don't have the problem that it is on by default so I assume you have a macro that runs automatically to do this for you. If you can isolate it then you will solve the problem
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  9. #9
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    I think I have found a way to create that strange behaviour:

    Make a new document, for example based on Normal.Dot,
    Check the "Automatically Update Document Styles" under Tools, Templates and Addins,
    Save as Normal2.DOT (as a template).
    Rename Normal.DOT to Normalold.DOT, and Normal2.DOT to Normal.DOT, and all new documents will have the setting!

    So it would be best to rename your normal.DOT to let Word create a new one, and copy any customiozations to that virgin Normal.DOT.

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>Klaus

  10. #10
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hi Jen:

    You're right. I misread the problem & that macro will turn off "Automatically update" in the style box for all styles. Microsoft uses too many "automatically etc.". But I think Klaus has hit the problem. Your normal.dot probably has "Automatically update document styles" turned on. I think you can just open normal.dot itself & make the change.

  11. #11
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,049
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hi,

    1) IMO you do not want to be creating a customized normal.dot for people any more than you want to be reorganizing their personal desk drawers. You should be using a combination of global and document templates.

    2) Bullets and numbering are governed by the list templates (which have very little to do with what Word calls templates under all other circumstances). Per John McGhie - who is nearly always right about such things - the formatting in the list template will override the formatting of the style.

    3) I would recommend you read <A target="_blank" HREF=http://www.mvps.org/word/FAQs/Numbering/WordsNumberingExplained.htm>Word's Numbering Explained</A> by John McGhie
    <A target="_blank" HREF=http://www.mvps.org/word/FAQs/Numbering/CureListNumbering.htm>Cure Word's Numbering Problems with a Dose of VBA</A> by Dave Rado (unfinished but good links)
    and perhaps
    <A target="_blank" HREF=http://www.addbalance.com/usersguide/numbering.htm>Numbering Chapter of Intermediate Users' Guide to Word</A>

    Hope this helps,
    Charles Kyle Kenyon
    Madison, Wisconsin

  12. #12
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Or, more simply, just locate the existing Normal.dot, open it, go to the Tools >Templates & Add-Ins, turn off the checkmark, OK, Save and Close (as Phil also suggests below).

    And to second Charles' comments, it's best not to use Normal.dot for the purpose described anyway - 'workgroup' and global templates are a better way to go.

    Gary

  13. #13
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Morning all.

    Andrew Lockton: Yes, I have that code. I've added it into my normal.dot and it doesn't fire (or something else overwrites it).

    Phil/Klaus/Gary: Actually, I've tried that ... I've tried to modify the normal.dot and turn off the setting; it doesn't save it. This is why I feel like I'm going nuts!

    Charles: We are a law firm, and we create a default normal.dot for users to define our base settings (like font, heading styles, etc.) rather than requiring that users set those themselves. Our goal is to only provide the normal.dot once; we do not push it down to users on a regular basis, because we want them to be able to make their own modifications to styles and other formatting based on their own practices. The problem is, we can't control what font and style definitions are part of a "virgin" normal.dot, so we have to create it ourselves. For example, our firm uses the Garamond 12 pt font for all documents. And, we have specific styles that need to be available to all documents regardless of the document template.

    And as for the numbering...the problem is not related specifically to styles with numbering/bullet attributes. That was just what I used as an example.

    I will try letting Word create its default normal.dot and then copy my settings into that per Klaus's suggestion; maybe that will resolve it.

    Thanks to everyone for your responses...

    Jen

  14. #14
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Chicago, Illinois, USA
    Posts
    185
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Ah, look at that. I found an edit post button.

    Cool.

    In any event, Klaus's suggestion worked, sort of; the normal.dot that Word first had the setting turned on again. I deleted *that* normal.dot again, and I let Word create a second normal.dot (finally, that setting was gone). Then re-did all of my customization. So, thank you Klaus!

    I'm still confused, though...I have searched through my normal.dot (the old one) in the VBA editor multiple times for the code Andrew Lockton mentioned earlier, and it doesn't appear anywhere in the template as far as I can see. Is it possible to have "hidden" code in the normal.dot?

    In any event, thanks to all of you for your help.

    Jennifer Klyse

  15. #15
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off Automatically Update Document Styles (Office 2000 SR1)

    Hi Jennifer,

    Tools > Templates and Add-Ins > Automatically update document styles:
    There isn't any code needed for that setting to be checked in the template.

    In a normal template, "Automatically update document styles" is de-activated and can't be activated.
    But if you have a document with that setting checked and save it as a template, it stays activated and can't be un-checked.
    So all new documents based on that template will have the setting.

    I reported this as a bug to Microsoft.

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>Regards, Klaus

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •