Results 1 to 11 of 11
  1. #1
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts

    Opening up Word Documents in Windows 7

    When opening up word using windows7, I would like to change the settings that only word documents are displayed. At present it displays both Word & Excel documents when opening up Wodrd documents

    Your assistance will be most appreciated

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,571
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    Which version of Office?

    Are you opening Word the using File | Open? Or are you double clicking on a document in Windows Explorer?

    Joe

  3. #3
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi Joe

    Thanks for the reply. I am using Office 2007. I am opening Word using File|Open, but even though Word documents have been selected, both word & Excel ocuments show in the folder. If I open up Word documents on Windows 7, I only want word documents to show. When I open up Excel, onlyExcel documents shows on the folder, which is great.

    It would be appreciated if you could assist

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    Howard,

    Do you have the file filter set to DocX?
    Attached Images Attached Images
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts

    Opening up Word documents in Windows 7

    Hi RG

    Thanks for the reply and for your assistance in resolving the matter. The File filter was set to all Word Documents. When I set this to Wod Documents .docx, it shows only word documents

    Regards

    Howard

  6. #6
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Hi RG

    I have just established the if ones used the filter .docx and you type in a name for eg how* all files i.e Excel & Word appears

    However, if one only uses the filter .docx, then only word documents appear. How can I overcome the problem that If I type in the name of a file for eg how* and filter Word Documents .docx, that only the word documents begining with How will appear and not Excel files?

    Your assistance will be most appreciated

    Regards

    Howard

  7. #7
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Howard,

    It appears the filter will allow you to show the type documents in the document library view pane that you have chosen to display. However when you start typing a name in the file name search box, the filter you have chosen is not used and all files with that name will appear in the drop down box. This appears to be an "either/or" situation where you use either the file name search box or the filter box, at least on my PC. Perhaps someone will have a way of setting this so instead of "either/or" the filter can be set for "and".
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  8. #8
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts

    Opening up Word documents in Windows 7

    Hi Ted

    Thanks for the reply and explanation. It is a bit of a pain, when one opens up word document using a wildcard for eg how* and all files are shown in the folder

    Regards

    Howard

  9. #9
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,397 Times in 1,220 Posts
    Quote Originally Posted by HowardC View Post
    Hi Ted

    Thanks for the reply and explanation. It is a bit of a pain, when one opens up word document using a wildcard for eg how* and all files are shown in the folder

    Regards

    Howard
    It's not a Word problem. It will happen with any application that uses a similar OpenFileDialog. Word requires .Net 3.5 and I would guess it uses .Net file open and save dialogs, which behave in this manner. Any application that uses them will behave like this. Some apps I have developed behave precisely like this, because they use these .net dialogs.

    It's even possible that these dialogs go a bit deeper and are based on something offered by Windows 7 itself, but I can't tell whether that happens or not.

    If you come to think of it, it's not a weird behavior. You just need to remember to add to your desired wildcard value a .doc* at the end.
    Last edited by ruirib; 2011-08-17 at 10:38.

  10. #10
    Bronze Lounger
    Join Date
    Feb 2008
    Posts
    1,420
    Thanks
    124
    Thanked 5 Times in 5 Posts
    Thanks for the info, this is much appreciated

  11. #11
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by HowardC View Post
    How can I overcome the problem that If I type in the name of a file for eg how* and filter Word Documents .docx, that only the word documents begining with How will appear and not Excel files?
    As long as you're typing anyway, add these 3 characters: .d*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •