Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Mar 2010
    Location
    Pennsylvania
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Folder permissions - allow modify, deny create

    I'm trying to lock down a network folder so that a particular group of users can open, modify and save the files that are already there, but will be unable to delete them, or add any new ones.

    At the moment, on the main permissions page, they have Allow rights for Modify, Read & Execute, List folder Contents, Read, and Write.

    On the Advanced Settings page, Effective Permissions tab, I see that they have a check for Create Files / Write Data. That seems to be almost the one I want, but why are those two permissions stuck together?

    I want them to be able to Write Data (that is, modify the existing files), but to be denied "Create Files" (add no new ones). Is there a way to do this?

    Thanks

  2. #2
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    On the folder, try tuning off Create Files / Write Data, and on the individual files try turning on Write permissions. This might let you update the file, but not update the directory (i.e., add or remove a file).

    Also, be aware that some programs don't update existing files - instead then create new files with the updated content and remove the old file.

  3. #3
    New Lounger
    Join Date
    Mar 2010
    Location
    Pennsylvania
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks... I'll give that a shot.

  4. #4
    New Lounger
    Join Date
    Mar 2010
    Location
    Pennsylvania
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ah, no luck. Here's what I did, and how it looked.

    1. Had a user access the file, make changes, save/close it. All normal.
    2. Checked folder-level permissions for that group. They had Modify, Read & Execute,List Folder Contents, Read, Write all checked for "Allow".
    3. Went into Advanced Security Settings. Clicked on that group, and then "Edit".
    4. "Create Files / Write Data" was checked when I got there. I unchecked that.
    5. Closed out of those dialog boxes, and then went to permissions for the particular file within that folder.
    6. When I got there, Modify and Write were unchecked. I checked those two (turned them back on).
    7. I went back to Advanced Settings and checked the "Replace Permission Entries..." box, and Applied that.
    8. Had a user try again; she could still see and open the file, but was now unable to save it.
    9. Restored everything to the original settings.

    So that didn't do it. Any other ideas?
    Thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •