Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Jun 2002
    Location
    England
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Odd desktop failure

    Every so often my desktop stops responding. All the icons disappear and it does not respond to any mouse actions (left or right clicks clicks, click and drag). It seems that the explorer process that manages the desktop has stopped working, as if I kill it then restart explorer everything is fine. It's not a big issue in practice as I don't tend to put much on the desktop, but it would be nice to know what is going on.
    Cheers

    KeithC

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Unavailable network resources often cause hangs.

    Joe

  3. #3
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    Check the power settings - make sure the hard drive is not being shut down. Switch everything to always on as a test.
    Also look in event logs for explorer errors around the time of one of these events.
    Are temperatures OK?
    Also always suspect memory problems when weird things happen; run a good long memory test.
    Does this happen when system is idle, active or both? What are the system specs?

    Jock

  4. #4
    New Lounger
    Join Date
    Jun 2002
    Location
    England
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's not a total hang, nothing else seems to be affected. All applications, networking, etc., are working normally. I generally only notice if I want to get at something on the desktop, which isn't that often so it could be happening every few minutes and I wouldn't notice. Which also means that I have no idea what else is happening at the time it occurs. Not even whether it happens when idle (and I only notice it later) or when active. I do know that once the desktop icons disappear they never come back until the explorer process managing the shell is restarted.
    As suggested, I'll take a look in event logs. I suspect if it were memory or temperature related, I would notice issues in applications, but I don't.
    The system is a Lenovo W510 running Win 7 Professional SP1, 64-bit, 8GB memory
    Cheers

    KeithC

  5. #5
    New Lounger
    Join Date
    Jun 2002
    Location
    England
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Been a bit busy, but I did go through event viewer and couldn't see anything that gave a clue. This is still happening. In summary:
    - Explorer shell process is still running, but not displaying desktop icons, nor allowing right-click on the desktop
    - No other applications are affected
    - If I kill the process, I would expect it to restart, but it does not, I have to manually restart it
    - No evidence of it being due to network, disk or temperature problems.

    Any clues?
    Cheers

    KeithC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •