Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Columbus, Ohio
    Posts
    234
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Merge fields (Word 2000 sr1)

    I have been trying to understand merge fields for a while, with some luck. However the formulas don't seem to work. I have one field, "Payment", and another field "Term". I would like the document to insert those fields (which it does), but then I want it to do this calculation: Payment * Term to give me a total of payments. The help file gives me an example, but it isn't working. How should this read?

    thanks,

    Rick

  2. #2
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,049
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Merge fields (Word 2000 sr1)

    { = { Mergefield Payment } * { Mergefield Term } }

    (I may have the syntax or markers wrong on the mergefields but what you are really asking about is the formula field.) I suspect that the easiest way to actually get this into your merge document is to insert the two mergefields using the merge helper and then put the " * " between them. Then put the "= " in front. Finally, select the whole lot and press Ctrl-F9 which will put it all into a field. The spaces can be critical to the formula field.

    Look in help under formula field or follow the links on my <A target="_blank" HREF=http://www.addbalance.com/word/wordwebresources.htm#Fields> Word Web Resources Page - Fields</A> (addbalance.com/word/wordwebresources.htm), especially those to the Microsoft online reference and Cindy Meister's articles.
    Charles Kyle Kenyon
    Madison, Wisconsin

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Columbus, Ohio
    Posts
    234
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Re: Merge fields (Word 2000 sr1)

    Thanks

    Rick

  4. #4
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Columbus, Ohio
    Posts
    234
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Re: Merge fields (Word 2000 sr1)

    I spoke to soon!!
    After I did what you suggested, I got the same result that I had before, which is the display of the formula, not the results. For example, the payment is 200 and the term is 10, so I'm looking for it to display "2000", but instead, after I merge the data, it shows this: { 200 * 10 }. I played around with it and was able to right click on the field and chose "toggle field codes". This then produced the correct "2000" and my short term victory. I went into my documents that I have been working on this and made the corrections, I then merge the fields and get the same {200 * 10}, however, now it won't let me click on the merge document to toggle the field codes.
    Why 1) Was I able to toggle the field code once on a merged document, but not again; 2) didn't the application just produce the rusults of the formula (all other merged data fields were in their correct toggled mode); 3) How can something so simple possible be this difficult to do?
    I'm confident my spacing is correct on these formulas.

    Please help again!!!!

    Thanks,
    Rick

  5. #5
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Merge fields (Word 2000 sr1)

    Hi Rick: (answers interspersed)
    >>Why 1) Was I able to toggle the field code once on a merged document, but not again;

    I'm not sure what you did, unless you've created a form & protected it. That's one thing that will cause a "toggle field codes" option to be greyed out. In the example you posted, it looks to me like your spacing is off between the 200 & the 10. Maybe you can post the exact code that you're using.

    >>2) didn't the application just produce the rusults of the formula (all other merged data fields were in their correct toggled mode);

    Try pressing Alt+F9 to toggle to the results. You may have your template set up to show field codes. Why don't you shut everything, open the template, make sure Tools/Options/view/Field Codes is unchecked. Close & save your template. This will mean that future documents will default to results.

    Hope this helps.

  6. #6
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,049
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Merge fields (Word 2000 sr1)

    Try toggling the field codes before you run your merge.
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •