Results 1 to 9 of 9
  1. #1
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post

    Word 2010 adds fictitious entries to table of contents?

    I'm reviewing a document that several people worked on. I noticed that the first legitimate entry in the table of contents was preceded by a bogus entry for a "title" consisting of someone's name.

    I found that one of the contributors had added a cover letter to the document between the title page and the table of contents. The name was the name of the addressee from the letter's address.

    The text was in the Normal font. So was the preceding section divider.

    I finally got rid of the bogus entry by deleting the entire address and typing it in again. I have no idea why this happened, though, and I tried so many things before I got the bogus entry to go away that I'm really not sure what was necessary to fix it.

    Can anyone shed light on this incident?

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Did you preserve the original by any chance?

  3. #3
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Inexperienced Word users will sometimes change the font without changing the style. A heading 1 paragraph made to look like a normal paragraph with direct formatting is still in the heading 1 style. The fix is to apply the normal (or wanted) style.

    In previous versions of Word, the document map feature "guesses" that short, embellished (like bold) lines should be headings and applies a higher paragraph outline level (usually 1) to them. If one of the people who worked on the document used an earlier version of Word and the document map, that's very likely the cause. The fix is to select the paragraph and press Ctrl+q to clear direct paragraph formatting or enter the Paragraph dialog and change the paragraph outline level to body text. If you just want to get rid of the items in the TOC, you can modify the TOC field codes to delete the switch that causes the TOC to look for outline levels applied with direct formatting (\u).

    One of the first things I did with W2010 was test the navigation pane to see if it also produced this error. So far I have not been able to get W2010 to make the error (well, since the programmers must have deliberately put that feature in, they wouldn't see it as an error.

    Pam
    Last edited by PamCaswell; 2011-10-11 at 23:40. Reason: correction

  4. #4
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post
    Did you preserve the original by any chance?
    I didn't bother, but the document management system did.



    Inexperienced Word users will sometimes change the font without changing the style...
    That is not what happened here. I said "The text was in the Normal font." That was an oops -- I meant, "The text was in the Normal style." Actually, before I fixed the problem I tried changing it to a heading and back to Normal, without effect.

    If one of the people who worked on the document used an earlier version of Word and the document map, that's very likely the cause.
    Everybody here has the same version of Office. I suppose someone could have taken it home and edited it with an earlier version of Word, but... it seems unlikely.

  5. #5
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Quote Originally Posted by jsachs177 View Post
    I didn't bother, but the document management system did.

    Oh, good. Can you post a sanitized version?

  6. #6
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    The stray items showing up in your TOC are almost certainly in a Style that gets pulled in. Perhaps there is a style separator. In addition to looking at the formatting marks, check the styles by using Shift-F1 and checking both options.

    The only other possibility would be TC fields, but those don't get into documents by accident.
    Charles Kyle Kenyon
    Madison, Wisconsin

  7. #7
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post
    Yesterday I was surprised to find that one of my co-workers does have an old version of Word, so it's quite possible that she unintentionally changed the outline level at some point.

    Charles, in view of that I don't think your suggestion would help me solve the problem, but it was educational. I didn't know about Shift+F1 or the style separator before. Shift+f1 will certainly come in handy. The style separator is more esoteric, but it's good to know about.

  8. #8
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Quote Originally Posted by jsachs177 View Post
    Yesterday I was surprised to find that one of my co-workers does have an old version of Word, so it's quite possible that she unintentionally changed the outline level at some point.
    I can't tell you how glad I am to hear that. The document map has caused a lot of angst in editing circles for the past nine years. I've been telling people that in W2010 it is fixed (or rather its replacement, the navigation pane, doesn't seem to have that bit of programming). I was worried, though, when I read your last post. Even though we (the community of users) have figured out ways to fairly easily fix the messed up documents, I wouldn't be happy to see the problem back--particularly now that I use the navigation pane regularly.

    Pam
    Last edited by PamCaswell; 2011-10-06 at 09:25.

  9. #9
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    From my previous answer (with corrections in red):

    In previous versions of Word, the document map feature "guesses" that short, embellished (like bold) lines should be headings and applies a higher paragraph outline level (usually 1) to them. If one of the people who worked on the document used an earlier version of Word and the document map, that's very likely the cause.

    The fix is to select the paragraph and press Ctrl+q to clear direct paragraph formatting or enter the Paragraph dialog and change the paragraph outline level to body text. If you just want to get rid of the items in the TOC, you can modify the TOC field codes to delete the switch that causes the TOC to look for outline levels applied with direct formatting (\u).
    HTH,
    Pam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •