Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Jan 2010
    Location
    Jacksonville, FL, USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Slow file/folder refresh

    I'm having a problem that I've experienced before. When I make file or folder changes (renaming files, creating new folders, etc.) in an Explorer window, the changes don't appear for several seconds. I can use View > Refresh to see the changes immediately, but left to do it automatically, it can take up to 5 seconds for the changes to appear. This slowdown started a few weeks ago. I'm using Win7 Home Premium.

    The last time this slowdown occurred, the "solution" was that I did a clean re-install of Win7. This was done for other reasons, but one of the results was that the refresh occurred instantaneously, rather than taking several seconds. Any ideas?

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Something is running in the background grabbing system resources. Acouple of things to try, first Task Manager will show all running apps and services. Commonly all apps seem to thing they need to run in the background and this just ain't so. I would use What's In Startup to check what's starting with Windows. Stop all apps that do not need to be running in the background.

    WhatsInStartup.jpg

    Shutdown everything you don't need and see if there is a difference.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    New Lounger
    Join Date
    Jan 2010
    Location
    Jacksonville, FL, USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've stopped a few of the unnecessary services and even deleted one running app that I wasn't using any longer - Acronis True Image Home, but no change in the behavior.

    There isn't really a general slowdown of my pc. RAM usage at startup is around 35% (4GB) and my quad core is not being overly taxed. The problem seems to be that the file operation is being performed, but the screen is not being refreshed immediately. For example, if I delete a shortcut icon on my desktop, it may take 4 to 5 seconds for the icon to disappear, yet it's actually deleted. If I try to delete it a second time right after the first deletion, it will say the item could not be found, but the icon is still visible on the screen. Several seconds later, it will finally disappear. This is the same behavior as deleting a file or renaming a file. The operation seems to be accomplished, it just isn't being refreshed on the screen. I can manually refresh the screen with View > Refresh but it just won't refresh on its own immediately.

    edit: I just tried creating a new folder within another folder. It took a full 9 seconds for the folder to appear on the screen. If I hit View > Refresh, it will appear immediately.
    Last edited by scolumbo; 2011-10-06 at 09:14.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •