Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Jun 2001
    Posts
    531
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Frame causing trouble (97)

    Frame causing trouble
    I have an option group frame on my form that disables certain controls based on the frame value. When I hit a certain record though, the locks are applied, but then as you scroll thru the records either way, the same lock applies to all the records, locks that were not there a moment ago.

  2. #2
    4 Star Lounger
    Join Date
    Jun 2001
    Posts
    531
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Frame causing trouble (97)

    well I think I figured it out, the disabling procedure is this:

    For Each ctl In Me.pagePromoPreApproval.Controls
    If ctl.tag = "tagDealer" Or ctl.tag = "tagVu" Then
    ctl.Enabled = False
    End If
    Next ctl

    I

  3. #3
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Frame causing trouble (97)

    Is this code running on the On Current event - if not that may be your problem? Otherwise you may need to simply enumerate each of the controls on your form and set the property appropriately. In addition, your code is such that once the Enabled property is set to false, there is nothing to set it back to True on the next record.
    Wendell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •