Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Aug 2001
    Location
    Australia
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Styleref and unwanted forward slash

    I have inherited a W2003 document with few smarts. The company is now using W2007 but this document is still relevant and the requirement is to make it into a true template (.dotx). I am adding a Styleref field to the header to pick up the title of the document from the front page. This works fine except that I am getting an unwanted forward slash at the beginning of the text each time.

    I have googled this problem and believe it is caused by a Compatibiltiy Mode issue however I am yet to come across a solution that works for me.

    The title is the very first paragraph of the document with a style called 'Cover Title'. This style is not used anywhere else and there is no hidden text in front of it.

    So far I have tried deleting the style in W2003, saving it as .docx and then recreated the style. I have also tried to copy the whole document minus the last paragraph mark to a blank W2007 .docx. (At the moment the .dotx requirement has gone by the wayside until I sort this other bit out.)

    I am loathe to start from scratch in W2007 but also, sadly, I would just like to have a fix to add to my repertoire...

    Thanks,
    Rep

  2. #2
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,049
    Thanks
    124
    Thanked 119 Times in 116 Posts
    Try doing a sample template without recreating the old one that has a styleref field in it. I suspect that the forward slash is actually in your field. The field switches in StyleRef use a backslash.

    See Fields:Styleref and Microsoft:Styleref
    Charles Kyle Kenyon
    Madison, Wisconsin

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    I agree that it sounds as though there might be a problem in your field. Have you tried re-creating it through Insert > Field (or the equivalent on the ribbon)?

  4. #4
    New Lounger
    Join Date
    Aug 2001
    Location
    Australia
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your replies.

    I certainly initially thought it was the field causing the problem. Have already been down the delete and reinsert path. In fact I created a new style with 1pt white font and used it against a paragraph ahead of my 'Cover Title' style in the document. I then inserted a styleref to the new one before the styleref to Cover Title in the header i.e. {STYLEREF "Filler" \* MERGEFORMAT}{STYLEREF "Cover Title" \* MERGEFORMAT} but still get the foward slash appearing.

    I was relieved when I found this thread - so it's not just me - but when I tried to follow the instructions it didn't fix the issue for me.
    http://thedailyreviewer.com/windowsa...ield-105363016

    I also went down this trail:
    http://answers.microsoft.com/en-us/o...4-4fef28ab557e
    but hit another dead end.

    Charles - If I create a new document or template in W2007 everything is fine. I am rapidly coming to the conclusion that the document has just been edited too many times and that the only option is to start again.

    Thanks,
    Rep

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    If the problem is only on one page, can you Save As and strip it down to just the problem area, and then post that for examination?

    (Edit: This might not really advance your project if you think the document is corrupted and is better rebuilt, but I'm curious what is going on.)
    Last edited by jscher2000; 2011-10-27 at 16:45. Reason: Because...

  6. #6
    New Lounger
    Join Date
    Aug 2001
    Location
    Australia
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Not one to give up easily I seem to have fixed the problem. In case anyone is interested the solution was to create a new 'Cover Title 2' style and insert it after the 'Cover Title' one. Use StyleRef to link to the new style and blow away the old one.

    FYI this is the error message that appeared against the unresolved StyleRef field when I just deleted the 'Cover Title' style:

    Error! Use the Home tab to apply Cover Title to the text that you want to appear here.

    Must say that in all my years of using Word it is a new one on me but maybe it indicates to those more in the know what the root cause of the problem is/was.

  7. #7
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by rep View Post
    Error! Use the Home tab to apply Cover Title to the text that you want to appear here.
    Must say that in all my years of using Word it is a new one on me but maybe it indicates to those more in the know what the root cause of the problem is/was.
    Actually, I think that's just a friendly way of saying "style not found" or whatever the old error message was.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •